Home button does not take the user home when tapped on the keyboard layout selection menu

RESOLVED FIXED

Status

Firefox OS
Gaia::System::Status bar, Utility tray, Notification
P3
normal
RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: KTucker, Assigned: etienne)

Tracking

({regression})

unspecified
ARM
Gonk (Firefox OS)
regression

Firefox Tracking Flags

(blocking-b2g:2.5+, b2g-v2.0 unaffected, b2g-v2.1 unaffected, b2g-v2.2 affected, b2g-v2.5 affected, b2g-master verified)

Details

(Whiteboard: [2.5-Daily-Testing][Spark], URL)

Attachments

(3 attachments)

When the user taps the SHB on the Built-in Keyboard page, nothing happens. The user is not returned to the home screen. 

Repro Steps:
1) Update a Aries to 20151028104739
2) Open the "Messaging" app.
3) Tap the "Compose new message" icon.
4) Press and hold your finger on the "Language" button on the keyboard.
5) Press the "home button" on the device while on the "Built-in Keyboard" page.

Actual:
The user is not taken home. Nothing happens.

Expected:
The user should always be returned to the home screen after tapping the home button.

Environmental Variables:
Device: Aries 2.5 [Full Flash]
Build ID: 20151028104739
Gaia: 2e89362de40a6c9c36525d36317fa1ae8e67e143
Gecko: fc706d376f0658e560a59c3dd520437b18e8c4a4
Gonk: 2916e2368074b5383c80bf5a0fba3fc83ba310bd
Version: 44.0a1 (2.5)
Firmware Version: D5803_23.1.A.1.28_NCB.ftf
User Agent: Mozilla/5.0 (Mobile; rv:44.0) Gecko/44.0 Firefox/44.0

Repro frequency: 10/10 100%
See attached: video, logcat
(Reporter)

Updated

3 years ago
status-b2g-master: --- → affected
Flags: needinfo?(jmercado)
Whiteboard: [2.5-Daily-Testing][Spark][Systemsfe]
Created attachment 8680189 [details]
logcat_20151028_1247.txt
This also occurs on Flame 2.5 and Flame 2.2

The user is not returned home when tapping the home button on the built-in keyboard screen.

Device: Flame 2.5 (512mb)(KK)(Full Flash)
Build ID: 20151028030421
Gaia: 2e89362de40a6c9c36525d36317fa1ae8e67e143
Gecko: fc706d376f0658e560a59c3dd520437b18e8c4a4
Gonk: 205ac4204bbbb2098a8046444acba551ba5dc75a
Version: 44.0a1 (2.5)
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:44.0) Gecko/44.0 Firefox/44.0

Environmental Variables:
Device: Flame 2.2 (Full Flash)(KK)(512mb)
Build ID: 20151028032502
Gaia: 885647d92208fb67574ced44004ab2f29d23cb45
Gecko: 05144e035522
Gonk: bd9cb3af2a0354577a6903917bc826489050b40d
Version: 37.0 (2.2)
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0
QA Whiteboard: [QAnalyst-Triage+]
status-b2g-v2.2: --- → affected
(Reporter)

Updated

3 years ago
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage?]
[Blocking Requested - why for this release]:
User is not taken to home when tapping on the home button.

Can we get this checked on 2.1 and 2.0 if the built in keyboard page was in those branches.
blocking-b2g: --- → 2.5?
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(jmercado)
Keywords: qawanted
I'm unable to repro on 2.1 or 2.0

Environmental Variables: (Not affected)
Device: Flame 2.1
BuildID: 20150724001207
Gaia: 9dba58d18006e921546cec62c76074ce81e16518
Gecko: 41e10c6740be
Gonk: bd9cb3af2a0354577a6903917bc826489050b40d
Version: 34.0 (2.1) 
Firmware Version: v18D


Environmental Variables: (Not affected)
Device: Flame 2.0
BuildID: 20150722000204
Gaia: b16ba05481e577bc644ed8966f587a70fe2148e6
Gecko: a4df3e0df24b
Gonk: bd9cb3af2a0354577a6903917bc826489050b40d
Version: 32.0 (2.0)
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage?]
Flags: needinfo?(jmercado)
Let's get a regression window here.
status-b2g-v2.0: --- → unaffected
status-b2g-v2.1: --- → unaffected
Flags: needinfo?(jmercado)
Keywords: qawanted → regression, regressionwindow-wanted
QA Whiteboard: [QAnalyst-Triage?]
Update title and component per STR.

Set it to + for regression marked as P3 for corner cases (non-urgent bugs we should still fix before finishing a release).

The root cause might be still window mgmt, but moving this to input mgmt first since it's layout menu.
blocking-b2g: 2.5? → 2.5+
Component: Gaia::System::Window Mgmt → Gaia::System::Input Mgmt
Priority: -- → P3
Summary: Home button does not take the user home when tapped on the Built-in Keyboard page → Home button does not take the user home when tapped on the keyboard layout selection menu
Assignee: nobody → timdream
Whiteboard: [2.5-Daily-Testing][Spark][Systemsfe] → [2.5-Daily-Testing][Spark]
QA Contact: tianxu
There is no Flame v2.2 build in b2g-inbound / mozilla-inbound, so I try to do the regression in Nightly builds.

Nightly Regression Window:

Last Working Environmental Variables:(flash.sh)
Device: Flame KK 2.2
Build ID               20150121162503
Gaia Revision          e4f9b5da3751798f9cc5d95f302c30722cc11fca
Gaia Date              2015-01-21 00:25:40
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/4a90da67661e
Gecko Version          37.0a2
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150121.201218
Firmware Date          Wed Jan 21 20:12:28 EST 2015
Firmware Version       v18D v4
Bootloader             L1TC000118D0

First Broken Environmental Variables:(flash.sh)
Device: Flame KK 2.2
Build ID               20150122002808
Gaia Revision          e4f9b5da3751798f9cc5d95f302c30722cc11fca
Gaia Date              2015-01-21 00:25:40
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/4a90da67661e
Gecko Version          37.0a2
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150122.041326
Firmware Date          Thu Jan 22 04:13:37 EST 2015
Firmware Version       v18D v4
Bootloader             L1TC000118D0

First Broken Gaia & First Broken Gecko - issue DOES NOT repro
Build ID               20150122002808
Gaia Revision          e4f9b5da3751798f9cc5d95f302c30722cc11fca
Gaia Date              2015-01-21 00:25:40
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/4a90da67661e
Gecko Version          37.0a2
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150122.041326
Firmware Date          Thu Jan 22 04:13:37 EST 2015
Firmware Version       v18D v4
Bootloader             L1TC000118D0

Last Working Gecko & Last Working Gaia - issue DOES NOT repro
Build ID               20150121162503
Gaia Revision          e4f9b5da3751798f9cc5d95f302c30722cc11fca
Gaia Date              2015-01-21 00:25:40
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/4a90da67661e
Gecko Version          37.0a2
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150122.041326
Firmware Date          Thu Jan 22 04:13:37 EST 2015
Firmware Version       v18D v4
Bootloader             L1TC000118D0

Note: Last Working and Last Working has the same Gaia+Gecko versions.

This bug can't be repro after device reboots. When we flash gaia+gecko (shallow_flash.sh), this bug can't be repro anymore. So we can not determine whether the bug is gaia or gecko bug.
QA Whiteboard: [MGSEI-Triage+]
Keywords: regressionwindow-wanted
(Assignee)

Comment 8

3 years ago
The UtilityTray is stoping the propagation, which is sad because the UtilityTray is already switched to the HierarchyManager. Patch incoming.
Assignee: timdream → etienne
Component: Gaia::System::Input Mgmt → Gaia::System::Status bar, Utility tray, Notification
Created attachment 8681299 [details] [review]
[gaia] etiennesegonzac:bug-1219407 > mozilla-b2g:master
(Assignee)

Comment 10

3 years ago
Comment on attachment 8681299 [details] [review]
[gaia] etiennesegonzac:bug-1219407 > mozilla-b2g:master

Removed the legacy home event code and added tests to cover the HierarchyManager support.
Attachment #8681299 - Flags: review?(m)
Comment on attachment 8681299 [details] [review]
[gaia] etiennesegonzac:bug-1219407 > mozilla-b2g:master

lgtm. thanks!
Attachment #8681299 - Flags: review?(m) → review+
(Assignee)

Updated

3 years ago
Keywords: checkin-needed
(Assignee)

Comment 12

3 years ago
https://github.com/mozilla-b2g/gaia/commit/3c327686a3afec1f697bf9cd83a0727a70a20043
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Created attachment 8682928 [details]
AriesKK_v2.6.3gp

This bug has been verified as "pass" on the latest build of Aries KK v2.6 and Flame KK v2.6 512mb by the STR in comment 0.

Actual results: The user always returns to the home screen after tapping the home button.

See attachment:AriesKK_v2.6.3gp

Reproduce rate: 0/10

Device: Aries KK 2.6 (master) (Pass)
Build ID               20151104004249
Gaia Revision          61918ddd9ccce104c009e873e34a0791e125753a
Gaia Date              2015-11-03 17:22:30
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/f742b9412ed5aace90ad863b276faae0641090a8
Gecko Version          45.0a1
Device Name            aries
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.worker.20151104.000116
Firmware Date          Wed Nov  4 00:01:24 UTC 2015
Bootloader             s1


Device:Flame KK 2.6 512mb (master)(Pass)
Build ID               20151103150203
Gaia Revision          61918ddd9ccce104c009e873e34a0791e125753a
Gaia Date              2015-11-03 17:22:30
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/f742b9412ed5aace90ad863b276faae0641090a8
Gecko Version          45.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20151103.182550
Firmware Date          Tue Nov  3 18:26:03 EST 2015
Firmware Version       v18D v4
Bootloader             L1TC000118D0
status-b2g-v2.5: --- → affected
status-b2g-master: affected → verified
You need to log in before you can comment on or make changes to this bug.