Closed Bug 12195 Opened 21 years ago Closed 21 years ago

[DOGFOOD] caret cruft left after a backspace at end of line

Categories

(Core :: DOM: Editor, defect, P2)

x86
Windows NT
defect

Tracking

()

VERIFIED FIXED

People

(Reporter: buster, Assigned: kinmoz)

References

()

Details

(Whiteboard: [PDT+])

run editor (HTML or plaintext)
put the cursor at the end of any line (really the end, so if there is a trailing
space, be sure the caret is after the space.)
backspace while the caret is visible
notice the vertical line display cruft
backspace again while the caret has blinked off
no cruft
syd has requested this be a high priority dogfood bug
Severity: major → normal
Priority: P3 → P2
Target Milestone: M10
Status: NEW → ASSIGNED
Does this also affect Mac and Linux?
*** Bug 12206 has been marked as a duplicate of this bug. ***
I didn't see a problem with this on Linux.
Blocks: 12658
M11
Target Milestone: M10 → M11
Working on this now.
Status: ASSIGNED → RESOLVED
Closed: 21 years ago
Resolution: --- → FIXED
Caret fixes checked in. Please reopen if you continue to see problems.
Status: RESOLVED → VERIFIED
seems fine now....verified in 9/15 build.
Status: VERIFIED → REOPENED
Resolution: FIXED → ---
Actually, this is still a problem in the URL bar on Windows.
*** Bug 13804 has been marked as a duplicate of this bug. ***
Assignee: sfraser → kin
Status: REOPENED → NEW
Reassigning this, due to current focus on performance issues. Kin, this should be
pretty trivial, and it's going to be easier for you to find it on Windows than
for me to. Once you find the place where you need to turn off the caret, you can
use the stack-based StCaretHider in nsICaret.h to do so.
Status: NEW → ASSIGNED
Accepting bug. Moving to M12.
Status: ASSIGNED → RESOLVED
Closed: 21 years ago21 years ago
Resolution: --- → FIXED
Fix checked in:

    mozilla/layout/base/src/nsCaret.cpp  revision 1.31

Added code to DrawCaretWithContext() that makes sure that the caret doesn't hang
outiside the right edge of a frame.

r=sfraser@netscape.com
Status: RESOLVED → VERIFIED
verified in 10/6 build.
Whiteboard: [PDT+]
Putting on [PDT]+ radar.
*** Bug 16035 has been marked as a duplicate of this bug. ***
*** Bug 16989 has been marked as a duplicate of this bug. ***
You need to log in before you can comment on or make changes to this bug.