Confusing search placeholder text behavior

RESOLVED FIXED

Status

Marketplace
Consumer Pages
P2
normal
RESOLVED FIXED
2 years ago
2 years ago

People

(Reporter: chuck, Assigned: chuck)

Tracking

Avenir
Points:
---

Details

Attachments

(2 attachments)

(Assignee)

Description

2 years ago
Created attachment 8680373 [details]
searchlabel.mov

If we're going to focus search inputs when they are shown, we need to do something to make sure the placeholder text doesn't flash back and forth. (See attachment)

I'd suggest positioning labels behind the inputs, and display:none-ing them when there is a non-empty value in the input.
(Assignee)

Comment 1

2 years ago
Created attachment 8680379 [details]
searchlabel2.mov

Confusing behavior is also exhibited on desktop.

Updated

2 years ago
Duplicate of this bug: 1218896

Updated

2 years ago
Priority: -- → P2
(Assignee)

Updated

2 years ago
Assignee: nobody → charmston
(Assignee)

Comment 3

2 years ago
https://github.com/mozilla/fireplace/commit/4aa7ff1fb7e9e0f4ea49ebe996d7dab97684c054
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → FIXED

Comment 4

2 years ago
Please note my comment from https://bugzilla.mozilla.org/show_bug.cgi?id=1218896#c1 .
I think is no need to open another issue... if that is an issue and not an intended behavior.
Flags: needinfo?(charmston)
The difference is that it's left-justified instead of center-aligned, so it looks off-center. We can make that change if necessary, but it seems trivial. I don't know that the design specifies.
(Assignee)

Comment 6

2 years ago
That is unrelated to this bug. It was left aligned previously, I just fixed the confusing search placeholder behavior.
Flags: needinfo?(charmston)
You need to log in before you can comment on or make changes to this bug.