Firefox demands stronger encryption than my router's web xface can provide

RESOLVED DUPLICATE of bug 1182742

Status

()

defect
--
major
RESOLVED DUPLICATE of bug 1182742
4 years ago
4 years ago

People

(Reporter: mozilla, Unassigned)

Tracking

41 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Reporter

Description

4 years ago
User Agent: Mozilla/5.0 (Windows NT 5.1; rv:41.0) Gecko/20100101 Firefox/41.0
Build ID: 20151014143721

Steps to reproduce:

I tried to connect to my hardwired router at 192.168.1.200


Actual results:

<errorlog>
Secure Connection Failed
An error occurred during a connection to 192.168.1.200. The server certificate included a public key that was too weak. (Error code: ssl_error_weak_server_cert_key) 
Please contact the website owners to inform them of this problem.
</errorlog>

I *must* coax Firefox into connecting to my hardwired router so I can administer my LAN. If Firefox can't accommodate hardware web interfaces in the loc range (192.168.x.x), then I will switch to another browser that can.



Expected results:

Ideally, Firefox would recognize the 192.168 mask as a local connection and treated it more gently. In any case, Firefox's error page should have offered an override so that I could register an exception for a hardware xface that can't be modernized.

I need to admin my router NOW, and Firefox is preventing me from getting my work done! It's as if this feature in Firefox was designed by Microsoft!
Reporter

Updated

4 years ago
Severity: normal → blocker
OS: Unspecified → Windows XP
Priority: -- → P4
Hardware: Unspecified → x86
Reporter

Comment 1

4 years ago
This is not a duplicate of #440608, which was probably a LAN config problem, not a Firefox problem. What I am reporting is Firefox being unwilling to accommodate weak public keys on old local hardware. The hardware can't be reprogrammed, so Firefox needs an escape hatch, at least for the local net.

I still can't talk to my router, and it's just a few inches from my face, mocking me. Firefox, in its infinite wisdom, has taken control from me without considering this use case. For my installation, this is a drop-dead, uninstall Firefox tomorrow morning bug. I *MUST* be allowed to connect to my own LAN router!
Reporter

Updated

4 years ago
Summary: Firefox demands stronger encryption then my router's web xface can provide → Firefox demands stronger encryption than my router's web xface can provide

Updated

4 years ago
Severity: blocker → major
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Component: Untriaged → Security: PSM
OS: Windows XP → All
Priority: P4 → --
Product: Firefox → Core
Hardware: x86 → All
Resolution: --- → DUPLICATE
Duplicate of bug: 1182742
You need to log in before you can comment on or make changes to this bug.