iFrame not loading source

RESOLVED WORKSFORME

Status

()

--
major
RESOLVED WORKSFORME
17 years ago
17 years ago

People

(Reporter: FourWinds, Assigned: asa)

Tracking

Trunk
x86
Windows 98
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
Underneath the text on the Yellow Bar that says 'Random Site' there is an iFrame
object. This does not load the specified source file.

Comment 1

17 years ago
Reporter please include at least your mozilla build id when reporting bugs.

Comment 2

17 years ago
for me the site looks in Mozilla 0.9.7 exactly like in IE 5.5. In both the
iframe remains empty.
(Reporter)

Comment 3

17 years ago
------- Additional Comments From nine@detonation.org  2002-01-26 06:19 -------
for me the site looks in Mozilla 0.9.7 exactly like in IE 5.5. In both the
iframe remains empty.

************
I use IE5.5(SP2), Netscape 6 & IE6 (on PC) & IE on MAC to test and for me they 
all show the iFrame contents correctly. Mozilla does not. Sorry I can't add 
more.
(Reporter)

Comment 4

17 years ago
Build ID 2001122106

Comment 5

17 years ago
For me in both Mozilla 2002 01 23 04 and IE 5.0 the space remains empty.
(Reporter)

Comment 6

17 years ago
REF :Mozilla/5.0 (Windows; U; Win98; en-US; rv:0.9.7) Gecko/20011221
With a little playing and some searching on Netscape site I found the following:

Old doctype definition is
<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.0 Transitional//EN">

I tried 
<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 
Transitional//EN" "http://www.w3.org/TR/html4/loose.dtd">

and the frame contents display in Mozilla. However table sizes are messed up. 
see
http://www.megalithomania.com/index_loose.php

So I tried
I tried 
<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 
Transitional//EN" "http://www.w3.org/TR/html4/strict.dtd">

and, again, the frame contents display in Mozilla. However table sizes are 
messed up. see
http://www.megalithomania.com/index_strict.php

Both of these files work fine in IE5.5 (SP2).
(Reporter)

Comment 7

17 years ago
Sorted it at last

<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Frameset//EN">

does the trick!!

Comment 8

17 years ago
since this is a vague bug:

I see this is a problem on any cnet page that contains an iframe.  It doesn't
load the iframe source, I also checked this link to IE 5.0  and IE loads the
iframe content no problem..  shouldn't this be handled in any doc mode, not just
frameset?

http://news.com.com/2100-1001-829275.html?legacy=cnet&tag=lthd
(Assignee)

Comment 9

17 years ago
looks like this is working now. 
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Component: Browser-General → HTMLFrames
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.