Closed Bug 1219961 Opened 7 years ago Closed 7 years ago

Remove Everything.Me from About Firefox OS / FTU privacy page

Categories

(Firefox OS Graveyard :: Gaia::First Time Experience, defect, P2)

ARM
Gonk (Firefox OS)
defect

Tracking

(blocking-b2g:2.5+, b2g-v2.5 verified, b2g-master verified)

VERIFIED FIXED
FxOS-S10 (30Oct)
blocking-b2g 2.5+
Tracking Status
b2g-v2.5 --- verified
b2g-master --- verified

People

(Reporter: sfoster, Assigned: sfoster)

Details

(Keywords: late-l10n, Whiteboard: [systemsfe])

Attachments

(5 files)

Attached image ftu-privacy-e.me.png
If you click the 'More about your privacy' link from Geolocation page in FTU, you are offered 3 choices: 'Foxfood' (Firefox OS), Marketplace and EverythingMe. See screenshot. As we no longer use E.me in 2.5, this is both wrong and confusing.
[Blocking Requested - why for this release]: Large potential for confusion as we don't actually use the e.me smart collections anymore in 2.5
blocking-b2g: --- → 2.5?
With the removal of E.me option on this screen, we no longer need the "Mozilla" and "Other" section delimiters. In fact, as all the other "privacy" links in the FTU just take you direct to the Firefox OS privacy page this whole screen is a bit odd. I think we at minimum need some new visual treatment to deal with having a now empty "Other" section.
Flags: needinfo?(jsavory)
Here's how it looks if I remove the subheads and the 'Other' section altogether
Flags: needinfo?(jsavory)
Attachment #8680960 - Flags: ui-review?(jsavory)
Flagging as late-l10n, we'll be *removing* strings to patch this.
Keywords: late-l10n
Comment on attachment 8680978 [details] [review]
[gaia] sfoster:ftu-edotme-bug-1219961 > mozilla-b2g:master

This patch removes the Everything.Me privacy link from the FTU - which you get to from the Geolocation page in the FTU. We're not shipping E.me services anymore so this should get cut before we branch. 
As this removes the only other group on the page, I removed the sub-header too. 
I also removed the orphaned strings.
Attachment #8680978 - Flags: review?(rakhavan)
Comment on attachment 8680960 [details]
ftu-privacy-without-e.me.png

Looks good to me, just adding a ui-review? for Eric for quick visual feedback.
Attachment #8680960 - Flags: ui-review?(jsavory)
Attachment #8680960 - Flags: ui-review?(epang)
Attachment #8680960 - Flags: ui-review+
Comment on attachment 8680978 [details] [review]
[gaia] sfoster:ftu-edotme-bug-1219961 > mozilla-b2g:master

I tested the patch locally. LGTM
Attachment #8680978 - Flags: review?(rakhavan) → review+
Comment on attachment 8680960 [details]
ftu-privacy-without-e.me.png

Seems to follow the pattern of other screens so it looks good to me, thanks!
Attachment #8680960 - Flags: ui-review?(epang) → ui-review+
Assignee: nobody → sfoster
Keywords: checkin-needed
Priority: -- → P2
Whiteboard: [systemsfe]
blocking-b2g: 2.5? → 2.5+
Merged to master: https://github.com/mozilla-b2g/gaia/commit/d03052ed18909e86b54bfbe9ad5c23d63d478af0
Status: NEW → RESOLVED
Closed: 7 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
According to the STR of Comment 0, this bug has been verified as pass on latest Flame KK v2.6 and Aries KK v2.6.

Actual results: There is no E.me in 'About Firefox OS / FTU privacy page'.
See attachment: verified_Aries KK v2.6.png
Reproduce rate: 0/6


Device: Flame KK v2.6 (Pass)
Build ID               20151102150204
Gaia Revision          7954ff0cbd794a35499a1082bed273598f82ee6f
Gaia Date              2015-11-02 17:35:17
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/6275cd9c71b76891f6b6585dabc687bc443ab877
Gecko Version          45.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20151102.182914
Firmware Date          Mon Nov  2 18:29:28 EST 2015
Fireware Version       v18D v4
Bootloader             L1TC000118D0

Device: Aries KK v2.6 (Pass)
Build ID               20151103000930
Gaia Revision          7954ff0cbd794a35499a1082bed273598f82ee6f
Gaia Date              2015-11-02 17:35:17
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/9f69202d82752e093a653a8f15b0274e347db33a
Gecko Version          45.0a1
Device Name            aries
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.worker.20151102.233051
Firmware Date          Mon Nov  2 23:30:58 UTC 2015
Bootloader             s1
Status: RESOLVED → VERIFIED
QA Whiteboard: [MGSEI-Triage+]
Comment on attachment 8680978 [details] [review]
[gaia] sfoster:ftu-edotme-bug-1219961 > mozilla-b2g:master

[Approval Request Comment]
Blocker, missed by early branching
[Bug caused by] (feature/regressing bug #): Smart collections feature discontinued in v2.5
[User impact] if declined: Information in the FTU given about non-existent feature
[Testing completed]: Gaia-Try, tested on device
[Risk to taking this patch] (and alternatives if risky): Low risk, FTU-only change
[String changes made]: Obsolete strings removed from FTU
Attachment #8680978 - Flags: approval-gaia-v2.5?
Comment on attachment 8680978 [details] [review]
[gaia] sfoster:ftu-edotme-bug-1219961 > mozilla-b2g:master

This landed in 2.5. Updating approval flag

Thanks
Attachment #8680978 - Flags: approval-gaia-v2.5? → approval-gaia-v2.5+
According to the STR of Comment 0, this bug has been verified as pass on latest Flame KK v2.5 512mb and Aries KK v2.5.

Actual results: There is no E.me in 'About Firefox OS / FTU privacy page'.
See attachment: verified_Aries KK v2.5.png
Reproduce rate: 0/6


Device: Flame KK v2.5 512mb (Pass)
Build ID               20151117132020
Gaia Revision          28d63cf3bdc4417f7ad8cab2230f096bf9f6d3b5
Gaia Date              2015-11-17 07:35:12
Gecko Revision         http://hg.mozilla.org/releases/mozilla-b2g44_v2_5/rev/8f193d35090cdceac7a7de513244ef4cd976133f
Gecko Version          44.0a2
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.worker.20151117.123256
Firmware Date          Tue Nov 17 12:33:05 UTC 2015
Firmware Version       v18D v4
Bootloader             L1TC000118D0

Device: Aries KK v2.5 (Pass)
Build ID               20151117132925
Gaia Revision          28d63cf3bdc4417f7ad8cab2230f096bf9f6d3b5
Gaia Date              2015-11-17 07:35:12
Gecko Revision         http://hg.mozilla.org/releases/mozilla-b2g44_v2_5/rev/8f193d35090cdceac7a7de513244ef4cd976133f
Gecko Version          44.0a2
Device Name            aries
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.worker.20151117.123839
Firmware Date          Tue Nov 17 12:38:47 UTC 2015
Bootloader             s1
You need to log in before you can comment on or make changes to this bug.