Firefox Nightly crash on restart with WebExtension installed

RESOLVED DUPLICATE of bug 1218364

Status

()

Toolkit
WebExtensions: Untriaged
RESOLVED DUPLICATE of bug 1218364
2 years ago
2 years ago

People

(Reporter: wbamberg, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

2 years ago
I'm not sure if this is a WebExtension bug, but it only seems to happen with a particular WebExtension installed, so...

STR:

* start Firefox Nightly (45.0a1 (2015-10-29)) from the command line with a clean profile
* flip the about:config pref to allow unsigned add-ons
* install this add-on: https://github.com/mdn/webextensions-examples/tree/master/notify-link-clicks - it installs and seems to work fine (what it does: [1]) 
* open Firefox Preferences, uncheck the e10s setting, click OK to the dialog asking to restart
* Firefox restarts, then crashes. I get this in the command line:

[24552] ###!!! ABORT: Invalid backend: file /builds/slave/m-cen-m64-ntly-000000000000000/build/src/gfx/layers/client/ClientLayerManager.cpp, line 776
[24552] ###!!! ABORT: Invalid backend: file /builds/slave/m-cen-m64-ntly-000000000000000/build/src/gfx/layers/client/ClientLayerManager.cpp, line 776

I have tried with a different add-on[2], no crash.

[1] https://developer.mozilla.org/en-US/Add-ons/WebExtensions/Examples#notify-link-clicks

[2] https://developer.mozilla.org/en-US/Add-ons/WebExtensions/Examples#borderify
I can't reproduce this, but it looks the same as bug 1218364.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1218364

Updated

2 years ago
Iteration: --- → 45.1 - Nov 16
You need to log in before you can comment on or make changes to this bug.