Assertion when playing muted YouTube video with Browser App

RESOLVED DUPLICATE of bug 1139256

Status

()

Core
Audio/Video
RESOLVED DUPLICATE of bug 1139256
2 years ago
2 years ago

People

(Reporter: swu, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

2 years ago
When playing YouTube video with Browser App by TV simulator[1], I encountered the following assertion error very easily.

MOZ_ASSERT(position >= mLastGoodPosition, "cubeb position shouldn't go backward");

STR:
1. Run TV simulator
2. Launch Browser App
3. Go to YouTube and watch a video
4. Click |mute| icon and refresh

[1] https://developer.mozilla.org/en-US/Firefox_OS/TVs_connected_devices
(Reporter)

Comment 1

2 years ago
Created attachment 8681009 [details]
GDB backtrace

Here is the GDB backtrace.
(Reporter)

Comment 2

2 years ago
This can be reproduced with Browser App on B2G desktop of phone build as well.

Revised STR:
1. Run TV simulator
2. Launch Browser App
3. Go to YouTube and watch a video
4. Click |mute| icon and make sure the video is playing
5. Click Refresh button
6. Repeat step 5 several times until assertion happens
Depends on: 1139256
Summary: Assertion when playing YouTube video with Browser App by TV simulator → Assertion when playing muted YouTube video with Browser App
Hi Shian-Yow,
Can you check if bug 1139256 fixes the problem here?
Flags: needinfo?(swu)
(Reporter)

Comment 4

2 years ago
(In reply to JW Wang [:jwwang] from comment #3)
> Hi Shian-Yow,
> Can you check if bug 1139256 fixes the problem here?

I tested and confirmed the problem doesn't happen.  Thanks for fixing it!
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Flags: needinfo?(swu)
Resolution: --- → DUPLICATE
Duplicate of bug: 1139256
You need to log in before you can comment on or make changes to this bug.