Closed Bug 1220028 Opened 6 years ago Closed 3 years ago

[Woodduck][System][TP Frozen]App frozen because of multi-window's state are "active" in system

Categories

(Firefox OS Graveyard :: Gaia::System, defect, P1)

ARM
Gonk (Firefox OS)
defect

Tracking

(Not tracked)

RESOLVED WONTFIX

People

(Reporter: binjian.tu.hz, Unassigned)

References

Details

Attachments

(2 files)

Attached file logs-snashots.rar
Description:
The screen is frozen at FM radio(can be Messages App or any other app) during following operations(See Reproduce method). Touch & tap any point in FM radio, no response.
1. Press or long touch home key, cannot return to homescreen but vibration still responses.
2. Press volume up & down, it works as expectation.
3. Press Power key, the screen can be lighted on & off.
4. Long press power key, sleep menu is showed as expectation, all the options can be chosen and no frozen on that menu.
5. utility-tray can be dragged down and no frozen
6. Lockscreen works as expectation.

Reproduce method:
1. touch & tap(two fingers) on TP more than 1000 times.
2. launch any App more than 100 times with high frequency.
3. light on / off the screen more than 100 times.
4. Dial & answer calls more than 30 times.

Probability:
2 out of 8 MS during 3 hours test.

Analysis:
See the attachment(issue MS is frozen at Messages App).
issue.jpg is the snapshot of children window list under id="windows" node in system app in issue MS.
ok.jpg is the snapshot of children window list under id="windows" node in system app in MS without the issue.

We doubt some logical defect causes the wrong state in id="homescree" node.
It is impossible that both FM Radio and homescreen are activated at the same time under this circumstance.

And still, you can get the mtklog from:
http://pan.baidu.com/s/1gdKzjm7
https://drive.google.com/open?id=0Bz6aW3cbHgB8Y3RQV1VsVW4xbDg

====================================================
Analysis from Zhangjin:
Attachment:
Message-Contacts-Homescreen.log

Opened Logs in app_window.js and app_window_manager.js. Switch between Message/Contacts/Homescreen, and finally end at a state that Contacts and Homescreen are both 'active', Contacts covers above Homescreen and will not disappear when press home key.

======================================================
Message-Contacts-Homescreen.log2

another log, device freeze at Message.

I/GeckoDump(  166): [AppWindowManager][628.842]launchingapp://sms.gaiamobile.org
I/GeckoDump(  166): [AppWindowManager][628.845] current is app://homescreen.gaiamobile.org/index.html#root; next is app://sms.gaiamobile.org/index.html
I/GeckoDump(  166): [Dump: AppWindow][Messages][AppWindow_1][628.846]request RESIZE...active? ,false
I/GeckoDump(  166): [AppWindowManager][628.846]=== Active app now is: ,Messages,===

...

I/GeckoDump(  166): [AppWindowManager][628.962]handling launchapp
I/GeckoDump(  166): [AppWindowManager][628.963]launchingapp://communications.gaiamobile.org/contacts/index.html
I/GeckoDump(  166): [AppWindowManager][628.966] current is app://sms.gaiamobile.org/index.html; next is app://communications.gaiamobile.org/contacts/index.html
We have the following workaround solution since we don't know the root cause of this issue.
See the patch.
Flags: needinfo?(wehuang)
Assignee: wehuang → nobody
Status: ASSIGNED → NEW
Flags: needinfo?(wehuang)
See Also: → 1216870
Hi Etienne:

Sorry for keeping asking, do you think it's something related to Gaia:system so you'll be able to help, or it in fact points to other module so you can help advise me a more suitable person to look into?

Thanks in advance!
Flags: needinfo?(etienne)
(In reply to Wesly Huang (TAM) from comment #2)
> Hi Etienne:
> 
> Sorry for keeping asking, do you think it's something related to Gaia:system
> so you'll be able to help, or it in fact points to other module so you can
> help advise me a more suitable person to look into?
> 

The workaround is making some deep changes about how the window manager works, with performance implication and a good potential for regression.

I'm happy to help on Gaia master (or other gaia public branches) bugs, with STR based on those branches.
But I can only work on the "root" issues, can't help when there's bug with a non-reviewed workaround.
Flags: needinfo?(etienne)
Blocks: Woodduck
Firefox OS is not being worked on
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.