Fxos Youtube app video is low resolution compared to android

RESOLVED WONTFIX

Status

()

Core
Audio/Video: Playback
P3
normal
RESOLVED WONTFIX
3 years ago
a year ago

People

(Reporter: sotaro, Unassigned)

Tracking

unspecified
ARM
Gonk (Firefox OS)
Points:
---

Firefox Tracking Flags

(blocking-b2g:2.5?, platform-rel -)

Details

(Whiteboard: [platform-rel-Youtube])

Comment hidden (empty)
(Reporter)

Updated

3 years ago
Summary: xos Youtube app video is low resolution compared to android → Fxos Youtube app video is low resolution compared to android
(Reporter)

Comment 1

3 years ago
When I played youtube video on master nexus-5-l, its video resolution is lower than android nexus5.

I compared the following.
- Youtube app on master nexus-5-l
- Youtube app on nexus 5android 6.0.0 factory image.

[STR]
- start Youtube app
- Playback some videos in Youtube app
(Reporter)

Comment 2

3 years ago
[Blocking Requested - why for this release]: By using same hardware, Youtube app play lower resolution video on fxos compared to android.
blocking-b2g: --- → 2.5?
(Reporter)

Updated

3 years ago
See Also: → bug 1196262
Are you getting MSE on the YouTube app? The YouTube app on Android supports pre-caching. Are you comparing pre-cached vs downloaded? Try clearing the Android app's storage to see if that has an effect.

Updated

3 years ago
OS: Unspecified → Gonk (Firefox OS)
Priority: -- → P2
Hardware: Unspecified → ARM
Is this a regression? Sotaro, also see Anthony's questions in comment 3.
Flags: needinfo?(sotaro.ikeda.g)
(Reporter)

Comment 5

3 years ago
Hmm, I could not say if it is a regression just by casual comparison. I compared between android by using HDMI output, I checked the quality by using very big screen. But b2g v2.2 does not support HDMI out put.

b2g v2.2 and v2.5 has several differences like the following. I checked on nexus-5. By a casual check, n2.5's MES playback seems to have similar quality to v2.2 HQ playback. 

- b2g v2.2: mp4 playback
            When open youtube video video was not started. User can chose HQ or normal quality.
            Video quality was fixed during playback.
            Rendered video side was adjusted to fill width or height
               (landscape mode looks like to fill screen without fullscreen mode).

- b2g v2.5: MSE playback
            When open youtube video, video playback start automatically.
            Video quality is adjusted automatically during video playback.
            Rendered video size is same in portrait and landscape mode.
Flags: needinfo?(sotaro.ikeda.g)
(Reporter)

Updated

3 years ago
Flags: needinfo?(sotaro.ikeda.g)

Updated

2 years ago
platform-rel: --- → ?

Updated

2 years ago
Whiteboard: [platform-rel-Youtube]
Mass change P2 -> P3
Priority: P2 → P3

Updated

2 years ago
platform-rel: ? → -
FirefoxOS is now unsupported.
Status: NEW → RESOLVED
Last Resolved: a year ago
Flags: needinfo?(sotaro.ikeda.g)
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.