Closed Bug 1220056 Opened 6 years ago Closed 6 years ago

[Flame KK][FOTA/ OTA] After OTA update is downloaded and install it, device will reboot and enter the recovery mode successfully.

Categories

(Firefox OS Graveyard :: Gaia, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(b2g-v2.5 affected)

RESOLVED DUPLICATE of bug 1214737
Tracking Status
b2g-v2.5 --- affected

People

(Reporter: tianxu, Unassigned)

References

Details

(Whiteboard: smoketest)

Attachments

(1 file)

[1.Description]:
[Flame KK v2.5][FOTA/ OTA]After OTA update is downloaded, and then tap "install now" button, device will reboot and then enter the recovery mode automatically.
See attachment: Flame KK v2.5 user.3gp.

[2.Testing Steps]: 
1. Open the settings app. 
2. Select Device Information. 
3. Tap on "Check Now" and wait up to 2 minutes for the notification to appear. 
4. Drag down the notification bar. 
5. Select the system updates notification dialog. 
6. Select Download.
7. After download, tap "install now" button. device will reboot.

[3.Expected Result]: 
7. Reboot successfully and enter the FTU screen.

[4.Actual Result]: 
7. It will enter the recovery mode automatically, and OTA will be fail.

[5.Reproduction build]: 
Device: Flame KK 2.5 user(Affected)
Build ID               20151029150245
Gaia Revision          91cac94948094cfdcd00cba5c6483e27e80cb3b0
Gaia Date              2015-10-28 20:32:15
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/1fbc958f75576446a57cf93406db87b51b12911d
Gecko Version          45.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20151029.182402
Firmware Date          Thu Oct 29 18:24:11 EDT 2015
Firmware Version       v18D v4
Bootloader             L1TC000118D0

[6.Reproduction Frequency]: 
Always Recurrence,5/5

[7.TCID]: 
2313
Attached video Flame KK v2.5 user.3gp
I think it's a duplicate of the following bug: https://bugzilla.mozilla.org/show_bug.cgi?id=1214737
See Also: → 1214737, 1219918
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1214737
Note, we need the recovery log....
Actually reopening this since I think we found the issue.
For the flame it's adding a \r \n at the end when you show the fingerprint.
adb shell getprop |grep fingerprint|od -c
0000000    [   r   o   .   b   u   i   l   d   .   f   i   n   g   e   r
0000020    p   r   i   n   t   ]   :       [   q   c   o   m   /   f   l
0000040    a   m   e   /   f   l   a   m   e   :   4   .   4   .   2   /
0000060    K   O   T   4   9   H   /   e   n   g   .   c   l   t   b   l
0000100    d   .   2   0   1   5   1   1   0   8   .   0   6   4   5   5
0000120    7   :   u   s   e   r   d   e   b   u   g   /   t   e   s   t
0000140    -   k   e   y   s   ]  \r  \n                                
0000150
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
nhirata-19333:Desktop nhirata$ adb shell getprop ro.build.fingerprint|od -c
0000000    q   c   o   m   /   f   l   a   m   e   /   f   l   a   m   e
0000020    :   4   .   4   .   2   /   K   O   T   4   9   H   /   e   n
0000040    g   .   c   l   t   b   l   d   .   2   0   1   5   1   1   0
0000060    8   .   0   6   4   5   5   7   :   u   s   e   r   d   e   b
0000100    u   g   /   t   e   s   t   -   k   e   y   s  \r  \n        
0000116
After reexamining the issue.  It's an error in the error message not an error in the error.

You need to be on the 18D base image in order to FOTA.  Otherwise it's a dup of bug 1214737.
Rather v18D_nightly_v4 as the base build.
Status: REOPENED → RESOLVED
Closed: 6 years ago6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1214737
You need to log in before you can comment on or make changes to this bug.