Closed Bug 1220067 Opened 6 years ago Closed 6 years ago

[Bluetooth] Support virtual call (SCO connection between AG and HF)

Categories

(Firefox OS Graveyard :: Bluetooth, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1091417

People

(Reporter: wiwang, Assigned: wiwang)

References

Details

Support virtual call.

Virtual call is not part of HFP spec, however it's about opening a SCO connection (between AG and HF) which can be utilized by upper applications then.

For example,
application(on AG) can use SCO connection to send/receive audio to/from HF to achieve some functionalities, such as VoIP, voice dialing, audio/voice recording, voice control, WebRTC.

- API issue
Since virtual call is a function related with upper application, we should consider more about the App permission(such as usage for privileged App), please refer to bug 1091417.
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1091417
You need to log in before you can comment on or make changes to this bug.