Closed Bug 1220197 Opened 4 years ago Closed 2 years ago

Addon is not disabled if on the block list.

Categories

(Firefox OS Graveyard :: General, defect, P1)

defect

Tracking

(feature-b2g:2.5+)

RESOLVED WONTFIX
feature-b2g 2.5+

People

(Reporter: nhirata, Unassigned)

References

Details

Attachments

(4 files)

1. flash the device
a) For aries install : https://tools.taskcluster.net/task-inspector/#NVn1sh1lQme4wf4Rx3iXCQ/0
b) For flame install : https://tools.taskcluster.net/task-inspector/#CUUGoT7_Rs69FYNmyjdgbw/0
2. make sure you have settings -> developer -> Debugging via USB = ADB and DevTools
3. make sure Settings->Developer->Use Marketplace Reviewer Certs is checked (you'll also see this in Device Settings as dom.mozApps.use_reviewer_certs)
With WebIDE:
4. In Device Settings, add the string value of dom.mozApps.signed_apps_installable_from to https://marketplace.firefox.com,https://marketplace.allizom.org,https://marketplace-dev.allizom.org
5. add string :  extensions.blocklist.url with value 
https://blocklist.allizom.org/blocklist/3/%APP_ID%/%APP_VERSION%/%PRODUCT%/%BUILD_ID%/%BUILD_TARGET%/%LOCALE%/%CHANNEL%/%OS_VERSION%/%DISTRIBUTION%/%DISTRIBUTION_VERSION%/%PING_COUNT%/%TOTAL_PING_COUNT%/%DAYS_SINCE_LAST_PING%/
6. set pref("extensions.blocklist.interval", 30);
7. wait 30 seconds.
8 reboot the device
9 check addons -> in settings.

Expected: the addon gets disabled
Actual: the addon doesn't get disabled.
oope.s  I forgot to mention in step 3.5 add "Unread Icons" from the marketplace in step 2.
I don't think this testing proves anything because waiting *just* 30 seconds is racy. Can you paste a logcat, to see the real blocklist url and content? Also, you don't need to reboot. You should see the addon being disabled in the settings app.
Shouldn't the Product be FxOS?
Attached file logcat.txt
I waited over 5 minutes as well.
The change never took place in settings/addons.
Flags: needinfo?(fabrice)
55733e2e9a834301b080e4d69a0f40ce
Thanks, so it's expected to be blocked by this snippet:

<emItem blockID="i921" id="55733e2e9a834301b080e4d69a0f40ce">
  <versionRange minVersion="0" maxVersion="100" severity="3">
  <targetApplication id="{3c2e2abc-06d4-11e1-ac3b-374f68613e61}">
    <versionRange minVersion="2.5" maxVersion="*"/>
  </targetApplication></versionRange>
  <prefs> </prefs>
</emItem>

This doesn't block because the minVersion="2.5" needs to be the gecko version. Or just don't add a versionRange here at all.
Updated to be blank. Ready for re-test?
Flags: needinfo?(nhirata.bugzilla)
Attached file update_test.zip
retest; still no change in settings. the webapps.json doesn't seem to have picked up the block.

zip file contains requested logcat and /data/local/webapps/webapps.json
Flags: needinfo?(nhirata.bugzilla) → needinfo?(fabrice)
I can't do much since I can't set up anything to download from marketplace-dev. I would need at least the manifest & the package to reproduce with a local server.
Flags: needinfo?(fabrice)
[Blocking Requested - why for this release]:
blocking-b2g: --- → 2.5?
Blocklisting does not work end to end.
Fabrice, attached is the webbapps.json and the addon itself from the phone.
Flags: needinfo?(fabrice)
blocking-b2g: 2.5? → ---
feature-b2g: --- → 2.5+
Priority: -- → P1
Odd.  I just checked on the Flame (which I left for testing the block) and the add on is disabled.

On my Aries device, ( which was turned off due to not enough power) the addon is still enabled.  Going to give it some time to see if it disables.
Can you re-test with a fresh aries build? There absolutely no device specific code there.
Flags: needinfo?(fabrice)
Component: Integration → General
Product: Marketplace → Firefox OS
Version: Avenir → unspecified
QA Whiteboard: [COM=Add-on]
Firefox OS is not being worked on
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.