Closed Bug 1220272 Opened 4 years ago Closed 4 years ago

Intermittent test_cache2-30d-pinning-WasEvicted-API.js | Test timed out

Categories

(Core :: Networking, defect)

44 Branch
defect
Not set

Tracking

()

RESOLVED FIXED
mozilla46
Tracking Status
firefox45 --- fixed
firefox46 --- fixed

People

(Reporter: KWierso, Assigned: mayhemer)

References

Details

(Keywords: intermittent-failure)

Attachments

(1 file)

Assignee: nobody → honzab.moz
Flags: needinfo?(honzab.moz)
Two theories:
- console bloat log (if even possible), Wes?
- duplicate of bug 913822, OTOH 40 entries and 300 seconds.. the disk would have to be super busy or slow

Bad is that the times in the console logs are not "real" but only shows time we print the lines captured from the test output after it has timed out.  Hence hard to say what phase would be that slow.
Flags: needinfo?(honzab.moz) → needinfo?(wkocher)
Reason is different.  More childish.  My mistake, forgot how to correctly signal to a different thread using a monitor.
Status: NEW → ASSIGNED
Flags: needinfo?(wkocher)
Duplicate of this bug: 1222217
It could happen IOThreadSuspender::Notify() was notified sooner than IOThreadSuspender::Run().  Notification to the monitor then didn't work.  I completely forgot how to do this stuff right.  Adding a flag to check on is the way.
Attachment #8708011 - Flags: review?(michal.novotny)
Attachment #8708011 - Flags: review?(michal.novotny) → review+
Keywords: checkin-needed
https://hg.mozilla.org/mozilla-central/rev/9c48dbddeeb6
Status: ASSIGNED → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla46
This affects Gecko 45 (the base of our next ESR release) - is this safe to backport to Beta as well?
Flags: needinfo?(honzab.moz)
(In reply to Ryan VanderMeulen [:RyanVM] from comment #19)
> This affects Gecko 45 (the base of our next ESR release) - is this safe to
> backport to Beta as well?

Definitely safe.  It's just a testing code, never executed in production.
Flags: needinfo?(honzab.moz)
Comment on attachment 8708011 [details] [diff] [review]
1220272-cache2-test-suspender-signalling.patch

Approval Request Comment
[Feature/regressing bug #]: cache2
[User impact if declined]: Intermittent oranges on ESR45 for the next year.
[Describe test coverage new/current, TreeHerder]: Covered by existing tests.
[Risks and why]: Per comment 20, the code touched is only used during testing.
[String/UUID change made/needed]: None
Attachment #8708011 - Flags: approval-mozilla-beta?
Comment on attachment 8708011 [details] [diff] [review]
1220272-cache2-test-suspender-signalling.patch

OK, let's take it to improve the testsuite.
Should be in 45 beta 3.
Attachment #8708011 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
You need to log in before you can comment on or make changes to this bug.