Lockscreen transitions incorrectly when opening to landscape app

RESOLVED DUPLICATE of bug 1129691

Status

RESOLVED DUPLICATE of bug 1129691
3 years ago
3 years ago

People

(Reporter: AdamA, Unassigned)

Tracking

({regression})

unspecified
ARM
Gonk (Firefox OS)
regression

Firefox Tracking Flags

(b2g-v2.2 unaffected, b2g-master affected)

Details

(Whiteboard: [2.5-Daily-Testing][Spark], URL)

Attachments

(1 attachment)

Created attachment 8681495 [details]
logcat

Description:
If the user has a landscape app open and then locks and unlocks the phone the transition from the lockscreen tot he landscape app will look inappropriate.

Repro Steps:
1) Update a Aries to 20151030120435
2) Open Swoop
3) Lock the phone
4) Unlock the phone
5) Observe the screen

Actual:
The phone will transition incorrectly to landscape apps

Expected:
It is ecpected that the lockscreen transitions to the app appropriately

Environmental Variables:
Device: Aries 2.5 [Full Flash]
Build ID: 20151030120435
Gaia: 91cac94948094cfdcd00cba5c6483e27e80cb3b0
Gecko: c2534acb485963331d67bbc5c07f0d862ed56bf5
Gonk: a19052e4389c3ae2d8fc3e7a74a475401baacc56
Version: 45.0a1 (2.5)
Firmware Version: D5803_23.1.A.1.28_NCB.ftf
User Agent: Mozilla/5.0 (Mobile; rv:45.0) Gecko/45.0 Firefox/45.0

Repro frequency: 10/10
See attached: video clip(https://youtu.be/mof3jq-yBpA), logcat
(Reporter)

Comment 1

3 years ago
This issue DOES occur in Flame 2.5.

Environmental Variables:
Device: Flame 2.5 [Full Flash]
BuildID: 20151030030240
Gaia: 91cac94948094cfdcd00cba5c6483e27e80cb3b0
Gecko: b41b92c09fcf94d077a54297aea1dc675b161a9d
Gonk: 205ac4204bbbb2098a8046444acba551ba5dc75a
Version: 45.0a1 (2.5) 
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:45.0) Gecko/45.0 Firefox/45.0

Result:
The phone will transition incorrectly to landscape apps
------------------------------------
This issue DOES NOT occur on Flame 2.2.

Environmental Variables:
Device: Flame 2.2 [Full Flash]
BuildID: 20151030032534
Gaia: 885647d92208fb67574ced44004ab2f29d23cb45
Gecko: b8b7f4efaa6e
Gonk: bd9cb3af2a0354577a6903917bc826489050b40d
Version: 37.0 (2.2) 
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0

result:
The lockscreen transitions appropriately
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
Keywords: regression
Status: NEW → RESOLVED
Last Resolved: 3 years ago
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
Resolution: --- → DUPLICATE
Duplicate of bug: 1129691
You need to log in before you can comment on or make changes to this bug.