[OMTC] Text in Style editor & Debugger blinks / changes resolution / changes blur level a few seconds after I finish scrolling it

NEW
Unassigned

Status

()

P3
normal
3 years ago
a year ago

People

(Reporter: arni2033, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(firefox41 affected, firefox42 affected, firefox43 affected, firefox44 affected, firefox45 affected, firefox-esr38 unaffected)

Details

(Whiteboard: [gfx-noted], URL)

(Reporter)

Description

3 years ago
STR:   (Win7_64, Nightly 45, 32bit, ID 20151029045227, new profile)
1. Open Debugger / Style editor on this page, choose a file that is long enough.
2. Scroll text down, wait ~5 seconds.

Result:       Text blinks / changes resolution / changes blur level. See video URL, because
              I don't know how to describe it better. On the video I move mouse up and down after text
              blinks / changes resolution / changes blur level (so that everybody could see that)

Expectations: Text shouldn't change its resolution/blur level

Regression range is the same as in bug 1185349. Markus, are you sure it wasn't caused by bug 1148022?
> pushlog_url:   https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=4d6d69f0f499dfc5c67df291858feda7bd2b9eac&tochange=d0fc7202b4cbe1ac8de823ed9e1e6dad706fc4d0
Flags: needinfo?(mstange)

Comment 1

3 years ago
dupe of bug 1180496 or bug 1172014 ?
(Reporter)

Comment 2

3 years ago
I'd like to know how is this supposed to be a dupe of bug 1180496 (= bug 1122916)
They look the same, but how does this work? Did bug 1148855 only enabled in Style editor & Debugger some rendering broken long time ago?
So if nobody stops me, I'll:   (1) mark this as dependant of bug 1122916
(2) once 1122916 is fixed, I'll check whether this is still happening and mark it as dupe if it's OK
Blocks: 1122916
Flags: needinfo?(mstange)
No longer blocks: 1122916
Depends on: 1122916
(In reply to arni2033 from comment #2)
> I'd like to know how is this supposed to be a dupe of bug 1180496 (= bug
> 1122916)
> They look the same, but how does this work? Did bug 1148855 only enabled in
> Style editor & Debugger some rendering broken long time ago?

Bug 1148855 causes bug 1122916 to happen in more cases than before. The devtools seem to hit such a case.
Whiteboard: [gfx-noted]
Duplicate of this bug: 1080740
Arni, can you still reproduce this with today's nightly?
Flags: needinfo?(arni2033)
(Reporter)

Comment 6

3 years ago
Currently the text is blurry all the time; It doesn't even switch back to normal. Is that "by-design" ? And also bug 1122916 comment 39 is still actual. I don't see why 1122916 is marked as fixed.
>>>   My Info:   Win7_64, Nightly 46, 32bit, ID 20151223030323
Flags: needinfo?(arni2033)
No longer depends on: 1122916
I think there are multiple bugs here:
 (1) With APZ, active scroll frames stay active and never deactivate (causing permanent blurriness).
 (2) For some reason, component alpha layers still don't result in subpixel text anti-aliasing for arni.
     I had hoped that bug 1072501 would fix this, but apparently there's more to do here.
 (3) It looks like even with working component alpha layers, there's a difference in rendering
     between layerized and flattened text here. We know that our component alpha compositing isn't
     perfectly accurate whenever the background isn't either pure black or pure white, but the difference
     seems much more noticeable than expected.
 (4) We do a bad job at layerizing the devtools. We should be able to pull the background color into the
     scrolled layer and not need component alpha layers in the first place.
(Reporter)

Updated

3 years ago
Has STR: --- → yes
Duplicate of this bug: 1237172
You need to log in before you can comment on or make changes to this bug.