[TV][browser] Revise pocket on TV menu item to "Pocket icon" + "Pocket"

VERIFIED FIXED in Firefox OS v2.5

Status

Firefox OS
Gaia::TV::Browser
P2
normal
VERIFIED FIXED
3 years ago
3 years ago

People

(Reporter: josh, Assigned: danhuang)

Tracking

unspecified
2.6 S1 - 11/20
ARM
Gonk (Firefox OS)
Dependency tree / graph

Firefox Tracking Flags

(blocking-b2g:2.5+, b2g-v2.5 fixed, b2g-master fixed)

Details

(Whiteboard: [partner-cherry-pick][ft:conndevices][partner-blocker])

Attachments

(5 attachments, 2 obsolete attachments)

(Reporter)

Description

3 years ago
Revise pocket on TV menu item to "Pocket icon" + "Pocket"
(Reporter)

Updated

3 years ago
See Also: → bug 1220381

Comment 1

3 years ago
Created attachment 8681738 [details]
pocket.png

Hi Peko,

The Browser menu item for Pocket will be changed to "Pocket icon" + "Pocket".
Could you provide the icon file format and size we need?
Flags: needinfo?(pchen)
Created attachment 8682897 [details]
Pocket.zip

Please see attached file for pocket layout.
Thanks
Flags: needinfo?(pchen)
(Reporter)

Comment 3

3 years ago
Hi Dan,
Could you help to revise the menu item as described?
Thanks!
Flags: needinfo?(dhuang)
(Reporter)

Updated

3 years ago
Target Milestone: --- → 2.6 S1 - 11/20
(Assignee)

Comment 4

3 years ago
Sure, I would take this.
Assignee: nobody → dhuang
Flags: needinfo?(dhuang)

Comment 5

3 years ago
Created attachment 8685264 [details]
pocket_v2.zip

Hi Dan, please check the new layout, thanks!
Flags: needinfo?(dhuang)
(Assignee)

Comment 6

3 years ago
Hi Tori, files in the pocket_v2.zip seems broken. Please help check the file and update attachment, thanks.
Flags: needinfo?(dhuang) → needinfo?(tchen)

Comment 7

3 years ago
Created attachment 8685279 [details]
pocket_v2.zip

File updated.
Attachment #8685264 - Attachment is obsolete: true
Flags: needinfo?(tchen) → needinfo?(dhuang)

Comment 8

3 years ago
Created attachment 8685319 [details]
pocket icon_white.png

new pocket icon
Attachment #8681738 - Attachment is obsolete: true
(Assignee)

Comment 9

3 years ago
got it !
Flags: needinfo?(dhuang)
Created attachment 8685330 [details] [review]
[gaia] danhuang1202:1220380_revise_pocket_menu_item_in_tv > mozilla-b2g:master
(Assignee)

Comment 11

3 years ago
Comment on attachment 8685330 [details] [review]
[gaia] danhuang1202:1220380_revise_pocket_menu_item_in_tv > mozilla-b2g:master

Hi Yi-fan, please help review. This patch update pocket menu item and revise toolbar.css, thanks.
Attachment #8685330 - Flags: review?(yliao)
Comment on attachment 8685330 [details] [review]
[gaia] danhuang1202:1220380_revise_pocket_menu_item_in_tv > mozilla-b2g:master

Thank you!

1. It seems we should change the string 'Pocket List' to 'Pocket' according to the spec?

2. The texts in the menu block are not vertically centered when hovering.

3. A couple questions on Github.
Attachment #8685330 - Flags: review?(yliao) → review+
(Assignee)

Comment 13

3 years ago
Created attachment 8688790 [details]
pocket_menu_spec_confirmed_with_ux.png

pocket menu item's padding size confirmed with UX
(Reporter)

Updated

3 years ago
Status: NEW → ASSIGNED
(Assignee)

Updated

3 years ago
Duplicate of this bug: 1225813
Blocks: 1223379
QA Whiteboard: [COM=TV Browser]
(Assignee)

Comment 15

3 years ago
Thanks for the review!
Merge in master:
https://github.com/mozilla-b2g/gaia/commit/de66b4eb6a0abf86dfe4ca511cc6868c136f3d08
Status: ASSIGNED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
(Assignee)

Comment 16

3 years ago
Comment on attachment 8685330 [details] [review]
[gaia] danhuang1202:1220380_revise_pocket_menu_item_in_tv > mozilla-b2g:master

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): Bug 1194109 
[User impact] if declined: strings and visual not align to spec
[Testing completed]: https://treeherder.mozilla.org/#/jobs?repo=gaia&revision=2fc7ecf3ff67370134bda1cf79cb8ba3c5273446
[Risk to taking this patch] (and alternatives if risky): None
[String changes made]: Yes
Attachment #8685330 - Flags: approval-gaia-v2.5?
(Reporter)

Updated

3 years ago
blocking-b2g: --- → 2.5+
status-b2g-v2.5: --- → affected
status-b2g-master: --- → fixed
(Reporter)

Comment 17

3 years ago
Comment on attachment 8685330 [details] [review]
[gaia] danhuang1202:1220380_revise_pocket_menu_item_in_tv > mozilla-b2g:master

Approve as part of Pocket feature in TV 2.5
Attachment #8685330 - Flags: approval-gaia-v2.5? → approval-gaia-v2.5+
I've just noticed that an icon was introduced with this commit which has not been compressed. It takes 300 KiB when it should take less than 1 KiB. Please run the compression script in the gaia tools and commit the compressed image instead (you'll need the optipng and advancecomp/advpng packages installed). From the gaia root directory execute the following command:

./tools/png_recompress -v \
    tv_apps/browser/style/images/pocket_icon.png
(Assignee)

Comment 19

3 years ago
Thanks for informing and kindly provide commend to compress png file. I created the follow up bug(Bug 1227836) to fix thie, thanks.
(Assignee)

Updated

3 years ago
Blocks: 1227836
Verified on:

Branch v2.2
Commit 93b8bf2de3258c25199d97036c50a87667059148
Author: yifan <yliao@mozilla.com>
Date:   Fri Nov 6 14:25:58 2015 +0800

Branch: master
Commit 7538cc11df132760010545f54379234a1862a8ae
Merge: 2e5f63b 43f67ab
Author: Ricky Chien <rickychien@users.noreply.github.com>
Date:   Wed Nov 25 18:38:29 2015 +0800
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.