Support ::selection pseudoclass

RESOLVED DUPLICATE of bug 509958

Status

()

defect
RESOLVED DUPLICATE of bug 509958
4 years ago
4 years ago

People

(Reporter: fresheneesz, Unassigned)

Tracking

41 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 years ago
User Agent: Mozilla/5.0 (Windows NT 6.3; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/46.0.2490.80 Safari/537.36

Steps to reproduce:

Tried to insertRule on a stylesheet object that include ::selection. 


Actual results:

Throws an exception.


Expected results:

It should work, just like sheet.insertRule('.whatever::-moz-selection { }', 2) works. Why does firefox only support the -moz- extension here?

Updated

4 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Component: Untriaged → CSS Parsing and Computation
OS: Unspecified → All
Product: Firefox → Core
Hardware: Unspecified → All
Resolution: --- → DUPLICATE
Duplicate of bug: 509958
You need to log in before you can comment on or make changes to this bug.