Closed Bug 1220486 Opened 6 years ago Closed 4 years ago

The urlbar (locationbar) dropmarker isn't always shown when I hover over toolbar (many inconsistencies)

Categories

(Firefox :: Theme, defect)

defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 1394517
Tracking Status
firefox45 --- affected

People

(Reporter: arni2033, Unassigned)

References

Details

Attachments

(2 files)

STR:   (Win7_64, Nightly 45, 32bit, ID 20151031030207, new profile)
1. Open new browser window, pin a tab in that window
2. Right-click australis menu button (≡), check "Show Menu bar", check "Show bookmarks toolbar"
3. Open many new tabs to cause overflow in #TabsToolbar
4. Scroll tab list to the 2nd tab (which is also 1st unpinned)
5. Hover over
   (A) place before pinned tab
   (B) place between start scrollbutton in tabs toolbar and 2nd tab
   (C) place between last tab and end scrollbutton (you may need to scroll tabs list to the end)
   (D) menu bar (Not the buttons in menu bar, COME_ON. The free space in menu bar)
   (E) bookmarks toolbar (again, I'm testing free space)
   (F) place between australis menu's separator and the last button in toolbar (there's 3px indent)
   (G) place above/under urlbar/searchbar (but still in the #nav-bar toolbar)

Expectations:
  Urlbar dropmarker should be visible in all cases (A-G). (all results below should be "+" or "/")

Result:       
  Result is represented as a table. I have tested this on normal & lwtheme, with and w/o title shown,
 in 3 window modes: normal, maximized, fullscreen. Columns are window modes ["(title)" means that
 title is shown], rows are tested places. In each table cell you can see the result of testing,
 in the format: "Normal result (Dev theme and all lwthemes result)"

Table:
                   Normal  |  Max  |  Full  |  Normal (title)  |  Max (title)  |  Full (title)
 Before 1st   (A)    -(/)     -(-)    +(/)         +(/)              +(+)            +(/)
 Before 2nd   (B)    -(-*)    -(-)    +(+)         +(+*)             +(+)            +(+)
 After last   (C)    -(/)     -(-)    +(/)         +(/)              +(+)            +(/)
 Menubar      (D)    -(-)     -(-)    /(/)         +(+)              +(+)            /(/)
 Bookmarks    (E)    +(-)     +(-)    /(/)         +(+)              +(+)            /(/)
 Separator    (F)    +(-)     +(-)    +(+)         +(+)              +(+)            +(+)
 Url/searchbar(G)    +(-)     +(-)    +(+)         +(+)              +(+)            +(+)

+   just as expected = dropmarker shown
-   not  as expected = dropmarker isn't shown
/   the described place doesn't exist
*   the described place doesn't exist usually, but I can trigger it using modified STR in bug 1203466

Notes:
  By the way, it's clear that this issue is caused by "-moz-binding"s, just like in bug 1195067
  Actually, if the bindings will be fixed to handle "hover" properly, that'll also fix bug 1219215

P.S. Brand new untested stuff makes me write much longer reports.   ._.
Has STR: --- → yes
Is is better demonstration of the changes made in bug 1211217.
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1394517
You need to log in before you can comment on or make changes to this bug.