Closed Bug 1220550 Opened 6 years ago Closed 6 years ago

Unlocked lockscreen's visibility is visible under homescreen and gets painted when launch an app

Categories

(Firefox OS Graveyard :: Gaia::System::Lockscreen, defect, P2)

ARM
Gonk (Firefox OS)
defect

Tracking

(blocking-b2g:2.5+, b2g-v2.5 fixed, b2g-master fixed)

RESOLVED FIXED
FxOS-S11 (13Nov)
blocking-b2g 2.5+
Tracking Status
b2g-v2.5 --- fixed
b2g-master --- fixed

People

(Reporter: ting, Assigned: gweng)

References

Details

Attachments

(1 file)

There're two BasicCanvasLayer::Paint() calls for #lockscreen-canvas when launch app [1], each takes ~40ms which should be unnecessary. Inspected #lockscreen-panel-main, it has visibility "visible" under homescreen.

[1] http://people.mozilla.org/~bgirard/cleopatra/#report=572cf9d4cc747456dc43f47120ce993a1d111037
    Gecko: 96377bdbcdf3
    Gaia: 01408e515ef12b238b51b5a088a1049bc8742d30
    Device: aries-kk
Assignee: nobody → gweng
Comment on attachment 8681808 [details] [review]
[gaia] snowmantw:bug1220550 > mozilla-b2g:master

Should be a simple change but a improvement of performance. Set the review.
Attachment #8681808 - Flags: review?(timdream)
Attachment #8681808 - Flags: review?(timdream) → review+
master: https://github.com/mozilla-b2g/gaia/commit/209ea46c6b62eed7f9e1a3e4a7cabab273cb2506
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
blocking-b2g: --- → 2.5+
Priority: -- → P2
Better have this on 2.5 as well.
v2.5 branch has been created. We need to get uplift approval. Please help to submit approval‑gaia‑v2.5:? 

Thanks.
Comment on attachment 8681808 [details] [review]
[gaia] snowmantw:bug1220550 > mozilla-b2g:master

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): Legacy CSS design
[User impact] if declined: Performance impact continues
[Testing completed]: Manually tested on my device since Gu was broken on our CI server yesterday
[Risk to taking this patch] (and alternatives if risky): No. It's really a simple change
[String changes made]: No
Attachment #8681808 - Flags: approval-gaia-v2.5?(mpotharaju)
From Raptor, I saw ~40ms improvement on Flame for many apps.
Blocks: 1180696
Comment on attachment 8681808 [details] [review]
[gaia] snowmantw:bug1220550 > mozilla-b2g:master

Approved to land on 2.5

Thanks
Attachment #8681808 - Flags: approval-gaia-v2.5?(mpotharaju) → approval-gaia-v2.5+
Set checkin-needed for v2.5.
Keywords: checkin-needed
(In reply to Greg Weng [:snowmantw][:gweng][:λ] from comment #9)
> Set checkin-needed for v2.5.

greg would it possible to submit a 2.5 PR request ?
Flags: needinfo?(gweng)
I've found it's already in the v2.5 branch:

https://github.com/mozilla-b2g/gaia/commit/209ea46c6b62eed7f9e1a3e4a7cabab273cb2506

So there is no need to do that. Thanks.
Flags: needinfo?(gweng)
Keywords: checkin-needed
Target Milestone: --- → FxOS-S11 (13Nov)
You need to log in before you can comment on or make changes to this bug.