[RTL] When swiping down the utility tray, the status bar icons jumps right.

RESOLVED FIXED in Firefox OS master

Status

Firefox OS
Gaia::System::Status bar, Utility tray, Notification
RESOLVED FIXED
2 years ago
2 years ago

People

(Reporter: autra, Assigned: autra)

Tracking

(Blocks: 1 bug)

unspecified
FxOS-S11 (13Nov)
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(b2g-v2.5 affected, b2g-master verified)

Details

Attachments

(3 attachments)

(Assignee)

Description

2 years ago
Created attachment 8681820 [details]
statusbar_icons_left.png

[Steps]
- put your phone in a RTL language
- open an application
- observe the status bar icons: they are left-aligned
- start to swipe down the utility tray
- observe the icons

[expected]
- they stay left-aligned

[actual]
- The icons jumps right, then back left when the utility tray has fully slid. See statusbar_icons_left.png
(Assignee)

Updated

2 years ago
Blocks: 1181944
(Assignee)

Updated

2 years ago
Assignee: nobody → augustin.trancart
Status: NEW → ASSIGNED
Created attachment 8681854 [details] [review]
[gaia] Phoxygen:bug1220561-system_statusbar_alignment > mozilla-b2g:master
(Assignee)

Comment 2

2 years ago
Comment on attachment 8681854 [details] [review]
[gaia] Phoxygen:bug1220561-system_statusbar_alignment > mozilla-b2g:master

Hi Tim, 

One rule was missing its RTL counterpart. Please R?
Attachment #8681854 - Flags: review?(timdream)
Comment on attachment 8681854 [details] [review]
[gaia] Phoxygen:bug1220561-system_statusbar_alignment > mozilla-b2g:master

I am sorry I am not familiar with this part of System app.
Attachment #8681854 - Flags: review?(timdream) → review?(apastor)
Comment on attachment 8681854 [details] [review]
[gaia] Phoxygen:bug1220561-system_statusbar_alignment > mozilla-b2g:master

Looks good. Thanks for taking care of this!
Attachment #8681854 - Flags: review?(apastor) → review+
(Assignee)

Updated

2 years ago
Keywords: checkin-needed
https://github.com/mozilla-b2g/gaia/commit/f7530dc80720bedacc797764fe774e11391d5234
Status: ASSIGNED → RESOLVED
Last Resolved: 2 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → FxOS-S11 (13Nov)
(Assignee)

Comment 6

2 years ago
Comment on attachment 8681854 [details] [review]
[gaia] Phoxygen:bug1220561-system_statusbar_alignment > mozilla-b2g:master

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): Bug 1179723
[User impact] if declined: In RTL, the status bar is misplaced and overlaps badly the hour.
[Testing completed]: on flame
[Risk to taking this patch] (and alternatives if risky): Low, only CSS change. No alternative, even backing out bug 1179723 might do more harm than good.
[String changes made]: none
Attachment #8681854 - Flags: approval-gaia-v2.5?
Created attachment 8683522 [details]
jump right_Aries&Flame kk master.png

This bug has been verified as "pass" on the latest build of Aries KK master and Flame KK master 512mb by the STR in comment 0.

Actual results: Swipe down the utility tray, status bar is left-aligned.
See attachment:jump right_Aries&Flame kk master.png.

Reproduce rate: 0/10

Device: Aries KK 2.6 (master) (Pass)
Build ID               20151105105137
Gaia Revision          e68d693cb55fb5d8946498eb2bdb63f55116d38e
Gaia Date              2015-11-05 01:05:27
Gecko Revision         n/a
Gecko Version          45.0a1
Device Name            aries
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.rose.20151103.153542
Firmware Date          Tue Nov 15:36:03 CST 2015
Bootloader             s1

Device: Flame KK v2.6 512mb (master)(Pass)
Build ID               20151104150239
Gaia Revision          47da49f8206788d70d834c3a63d9245d50c89103
Gaia Date              2015-11-03 21:48:23
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/6077f51254c69a1e14e1b61acba4af451bf1783e
Gecko Version          45.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20151104.182640
Firmware Date          Wed Nov  4 18:26:52 EST 2015
Firmware Version       v18D v4
Bootloader             L1TC000118D0
QA Whiteboard: [MGSEI-Triage+]
status-b2g-v2.5: --- → affected
status-b2g-master: --- → verified
(Assignee)

Comment 8

2 years ago
Comment on attachment 8681854 [details] [review]
[gaia] Phoxygen:bug1220561-system_statusbar_alignment > mozilla-b2g:master

Already in 2.5.
Attachment #8681854 - Flags: approval-gaia-v2.5?
You need to log in before you can comment on or make changes to this bug.