[Video] Videos with special format can't play, when you select one of the these files, it will pop up the prompt: " Another app is currently using the video player".

RESOLVED DUPLICATE of bug 1217220

Status

RESOLVED DUPLICATE of bug 1217220
3 years ago
3 years ago

People

(Reporter: huan.yang, Unassigned)

Tracking

({regression})

unspecified
ARM
Gonk (Firefox OS)
regression

Firefox Tracking Flags

(b2g-v2.2 unaffected, b2g-v2.5 affected, b2g-master verified)

Details

Attachments

(5 attachments)

(Reporter)

Description

3 years ago
[1.Description]:
[Aries KK_v2.6][Flame KK_v2.5 & v2.6][Video]When you select a video with special format in Video app, it will not play, but  the prompt that  Another app is currently using the video player will be shown.

See attachments: logcat_1649.txt and Aries KK_v2.6.3gp
Videos with special format: "Test video.mp4"  and  "Test video2.3gp"
Found time: 16:49

[2.Testing Steps]: 
Precondition:  Have some videos with special format , see the file from attactments.
1. Launch Video app.
2. Select a video with special format.

[3.Expected Result]: 
2. The video should play correctly, and there is no any prompt shown.

[4.Actual Result]: 
2. The video doesn't play, but the prompt that  "Another app is currently using the video player" will be shown.

[5.Reproduction build]: 
Device: AriesKK v2.6[Affected]
Build ID               20151101012023
Gaia Revision          91cac94948094cfdcd00cba5c6483e27e80cb3b0
Gaia Date              2015-10-28 20:32:15
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/96377bdbcdf3e444a22aeaa677da696243b00d98
Gecko Version          45.0a1
Device Name            aries
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.worker.20151101.004008
Firmware Date          Sun Nov  1 00:40:17 UTC 2015
Bootloader             s1

Device: FlameKK v2.6[Affected]
Build ID               20151101150206
Gaia Revision          91cac94948094cfdcd00cba5c6483e27e80cb3b0
Gaia Date              2015-10-28 20:32:15
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/96377bdbcdf3e444a22aeaa677da696243b00d98
Gecko Version          45.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20151101.183234
Firmware Date          Sun Nov  1 18:32:48 EST 2015
Bootloader             L1TC000118D0

Device: FlameKK v2.5[Affected]
Build ID               20151101004501
Gaia Revision          91cac94948094cfdcd00cba5c6483e27e80cb3b0
Gaia Date              2015-10-28 20:32:15
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g44_v2_5/rev/36d8fc192b45d26eb4d32bbeae19f79cb2aebb65
Gecko Version          44.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20151101.031103
Firmware Date          Sun Nov  1 03:11:16 EST 2015
Bootloader             L1TC000118D0

Device:Flame kk v2.2(Unaffected)
Build ID               20151101032508
Gaia Revision          885647d92208fb67574ced44004ab2f29d23cb45
Gaia Date              2015-10-07 13:05:24
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/b8b7f4efaa6e
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20151101.072435
Firmware Date          Sun Nov  1 07:24:47 EST 2015
Firmware Version       v18D v4
Bootloader             L1TC000118D0

[6.Reproduction Frequency]: 
Always Recurrence,10/10

[7.TCID]: 
Free Test

[8.Note]:
This bug can't be repro on flame v2.5 with the "Test video.mp4" .
(Reporter)

Comment 1

3 years ago
Created attachment 8681849 [details]
Aries KK_v2.6.3gp
(Reporter)

Comment 2

3 years ago
Created attachment 8681851 [details]
logcat_1649.txt
(Reporter)

Comment 3

3 years ago
Created attachment 8681852 [details]
Test video.mp4
(Reporter)

Comment 4

3 years ago
Created attachment 8681853 [details]
Test video2.3gp
(Reporter)

Updated

3 years ago
status-b2g-v2.2: --- → unaffected
status-b2g-v2.5: --- → affected
status-b2g-master: --- → affected

Comment 5

3 years ago
[Blocking Requested - why for this release]:
file format support regression issue
blocking-b2g: --- → 2.6?
Keywords: regression, regressionwindow-wanted

Updated

3 years ago
QA Contact: jthomas

Comment 6

3 years ago
Mozilla Inbound Regression Window

Last Working
Environmental Variables:
Device: Flame 2.6
BuildID: 20151029163913
Gaia: 91cac94948094cfdcd00cba5c6483e27e80cb3b0
Gecko: d3a2e391df48f1c9389bdc132eb72065442dc2db
Version: 45.0a1 (2.6) 
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:45.0) Gecko/45.0 Firefox/45.0

First Broken
Environmental Variables:
Device: Flame 2.6
BuildID: 20151029165112
Gaia: 91cac94948094cfdcd00cba5c6483e27e80cb3b0
Gecko: 9a44575026505c955bdda462d6ad346d197ab107
Version: 45.0a1 (2.6) 
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:45.0) Gecko/45.0 Firefox/45.0

Last Working gaia / First Broken gecko - This issue DOES occur with broken Gecko
Gaia: 91cac94948094cfdcd00cba5c6483e27e80cb3b0
Gecko: 9a44575026505c955bdda462d6ad346d197ab107

Last Working gecko / First Broken gaia - This issue does NOT occur with broken Gaia
Gecko: d3a2e391df48f1c9389bdc132eb72065442dc2db
Gaia: 91cac94948094cfdcd00cba5c6483e27e80cb3b0

Mozilla Inbound Pushlog:
http://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=d3a2e391df48f1c9389bdc132eb72065442dc2db&tochange=9a44575026505c955bdda462d6ad346d197ab107
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(jmercado)
Keywords: regressionwindow-wanted
John this issue has the same pushlog as bug 1220778 but seems even more like bug 1217220.  Can I get your thoughts?
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(jmercado) → needinfo?(jolin)
(In reply to Jayme Mercado [:JMercado] from comment #7)
> John this issue has the same pushlog as bug 1220778 but seems even more like
> bug 1217220.  Can I get your thoughts?

 Yes. I can play both video after applying the patch in bug 1217220.
 Marking this as dup.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Depends on: 1217220
Flags: needinfo?(jolin)
Resolution: --- → DUPLICATE
Duplicate of bug: 1217220

Comment 9

3 years ago
add verifyme in advance and need to verify this issue once bug1217220 is fixed
Keywords: verifyme
(Reporter)

Comment 10

3 years ago
This bug has been verified as pass on latest build of Aries KK v2.6 and Flame KK v2.6(512mb) by the STR in comment 0.
Actual results: The video can play correctly, and there is no any prompt shown.
See attactment: Verified_Flame_v2.6.3gp.
Reproduce rate: 0/10.

Device: Aries KK v2.6 (Pass)
Build ID               20151110120047
Gaia Revision          c0482775b1526add626b170dd53a72d10bcaf07c
Gaia Date              2015-11-10 02:25:52
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/cc473fe5dc512c450634506f68cbacfb40a06a23
Gecko Version          45.0a1
Device Name            aries
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.worker.20151110.111927
Firmware Date          Tue Nov 10 11:19:35 UTC 2015
Bootloader             s1

Device: Flame KK v2.6 512mb(Pass)
Build ID               20151110150205
Gaia Revision          c0482775b1526add626b170dd53a72d10bcaf07c
Gaia Date              2015-11-10 02:25:52
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/cc473fe5dc512c450634506f68cbacfb40a06a23
Gecko Version          45.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20151110.182433
Firmware Date          Tue Nov 10 18:24:47 EST 2015
Fireware Version       v18D v4
Bootloader             L1TC000118D0

Note: I will verify Flame v2.5 & Aires 2.5 if it is landed on b2g44 in Bug 1217220.
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage+][MGSEI-Triage+]
status-b2g-master: affected → verified
Keywords: verifyme
(Reporter)

Comment 11

3 years ago
Created attachment 8685827 [details]
Verified_Flame_v2.6.3gp

Updated

3 years ago
blocking-b2g: 2.6? → ---
You need to log in before you can comment on or make changes to this bug.