bugzilla.mozilla.org has resumed normal operation. Attachments prior to 2014 will be unavailable for a few days. This is tracked in Bug 1475801.
Please report any other irregularities here.

[TV] FTE for Casting video and website to TV

RESOLVED FIXED

Status

Firefox OS
Gaia::First Time Experience
P2
normal
RESOLVED FIXED
3 years ago
2 years ago

People

(Reporter: rexboy, Assigned: Fischer)

Tracking

unspecified
ARM
Gonk (Firefox OS)
Dependency tree / graph

Firefox Tracking Flags

(blocking-b2g:2.5+, b2g-v2.5 fixed, b2g-master fixed)

Details

(Whiteboard: [ft:conndevices][partner-blocker][partner-cherry-pick])

Attachments

(2 attachments)

Summary: [TV] FTE for Casting video to TV → [TV] FTE for Casting video and website to TV
Depends on: 1215006, 1216058
Not sure if we need to split casting website into another bug. We can open another one if needed.
Assignee: nobody → fliu
(Assignee)

Updated

3 years ago
Blocks: 1221857
(Assignee)

Updated

3 years ago
Blocks: 1221859

Updated

3 years ago
Status: NEW → ASSIGNED

Updated

3 years ago
Whiteboard: [ft:conndevices] → [ft:conndevices][partner-blocker][partner-cherry-pick]

Updated

3 years ago
Blocks: 1199525
No longer blocks: 1205944
Created attachment 8685980 [details] [review]
[gaia] Fischer-L:bug_1220584-send-video-to-tv-app > mozilla-b2g:master
(Assignee)

Comment 3

3 years ago
Created attachment 8686414 [details] [review]
PR #33135
Attachment #8686414 - Flags: review?(rexboy)
Comment on attachment 8686414 [details] [review]
PR #33135

Can you put your offline contents together for reviewing?
Attachment #8686414 - Flags: review?(rexboy)
(Assignee)

Updated

3 years ago
Attachment #8686414 - Flags: review?(rexboy)
Comment on attachment 8686414 [details] [review]
PR #33135

You need to figure out bower_components and change directory structure in some way.
And please resolve the focus problem. I guess the cause is you didn't focus on the Iframe.
Attachment #8686414 - Flags: review?(rexboy)
(Assignee)

Updated

3 years ago
Attachment #8686414 - Flags: review?(rexboy)
Comment on attachment 8686414 [details] [review]
PR #33135

r=me with 1 comment. Please make corresponding changes before merging.
Attachment #8686414 - Flags: review?(rexboy) → review+
(Assignee)

Comment 7

3 years ago
Land to Master: https://github.com/mozilla-b2g/gaia/pull/33135/commits
Test: https://treeherder.mozilla.org/#/jobs?repo=gaia&revision=8d73f8d781d5f6deecb017723b2a85d39a3b1f8c
Status: ASSIGNED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
I've just noticed that the icons that were introduced with this commit have not been compressed. They take over 4 MB of space whereas they could take ~1.5 MiB. Please run the compression script in the gaia tools and commit the compressed images instead (you'll need the optipng and advancecomp/advpng packages installed). From the gaia root directory execute the following command:

./tools/png_recompress -v \
    tv_apps/fling-tutorial/style/icons/fling-tutorial_336.png \
    tv_apps/fling-tutorial/style/index.css \
    tv_apps/fling-tutorial/style/offline_content/images/background.png \
    tv_apps/fling-tutorial/style/offline_content/images/cast_link_icon.png \
    tv_apps/fling-tutorial/style/offline_content/images/cast_video.png \
    tv_apps/fling-tutorial/style/offline_content/images/cast_video_icon.png \
    tv_apps/fling-tutorial/style/offline_content/images/cast_website.png \
    tv_apps/fling-tutorial/style/offline_content/images/phone.png

Be patient as this may take a while but the results are well-worth it. Besides the space savings we get faster load times, less memory use when decoding them and better caching.
(Assignee)

Updated

3 years ago
Blocks: 1227812
(Assignee)

Comment 9

3 years ago
@Josh,
This patch should be uplifted for TV 2.5. Thank you
Flags: needinfo?(jocheng)
(Assignee)

Comment 10

3 years ago
Comment on attachment 8685980 [details] [review]
[gaia] Fischer-L:bug_1220584-send-video-to-tv-app > mozilla-b2g:master

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): 1220584
[User impact] if declined: The use will not see the Send-to-TV tutorial
[Testing completed]: Yes
[Risk to taking this patch] (and alternatives if risky): Low
[String changes made]: No
Attachment #8685980 - Flags: approval-gaia-v2.5?
(Assignee)

Comment 11

3 years ago
[Blocking Requested - why for this release]:
blocking-b2g: --- → 2.5?
(Assignee)

Updated

3 years ago
Blocks: 1228927
(Assignee)

Updated

3 years ago
Blocks: 1228929

Updated

3 years ago
blocking-b2g: 2.5? → 2.5+
status-b2g-v2.5: --- → affected
status-b2g-master: --- → fixed
Flags: needinfo?(jocheng)

Comment 12

3 years ago
Comment on attachment 8685980 [details] [review]
[gaia] Fischer-L:bug_1220584-send-video-to-tv-app > mozilla-b2g:master

Approve for TV 2.5
Attachment #8685980 - Flags: approval-gaia-v2.5? → approval-gaia-v2.5+
(Assignee)

Updated

3 years ago
Depends on: 1242884
(Assignee)

Updated

2 years ago
Depends on: 1253183
(Assignee)

Updated

2 years ago
Depends on: 1262722
(Assignee)

Updated

2 years ago
No longer depends on: 1262722
You need to log in before you can comment on or make changes to this bug.