rewrite talos addons to be restartless and unsigned

RESOLVED DUPLICATE of bug 1249733

Status

Testing
Talos
RESOLVED DUPLICATE of bug 1249733
2 years ago
2 years ago

People

(Reporter: jmaher, Unassigned)

Tracking

(Depends on: 1 bug)

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

2 years ago
Once addon signing is enforced, all test extensions will either need to be signed, or to be installed at runtime using a mechanism which will only work with restartless addons - see bug 1209338.

I don't think it is realistic to sign all the talos addons (pageloader, tresize, damp, tps, cart), so we need to make these unsigned and figure out how to install them.

Comment 1

2 years ago
I had a restartless version of tart/cart, I'll dig it up. But I think the main issue might be pageloader since it's probably the least trivial of the bunch.
(Reporter)

Updated

2 years ago
Depends on: 1231626
(Reporter)

Updated

2 years ago
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1249733
You need to log in before you can comment on or make changes to this bug.