Reviewer parsing into metadata does not understand "ui-r", sometimes adds "ui-" to the list of reviewers

RESOLVED DUPLICATE of bug 1221999

Status

RESOLVED DUPLICATE of bug 1221999
3 years ago
3 years ago

People

(Reporter: Gijs, Unassigned)

Tracking

Details

(Reporter)

Description

3 years ago
Sometimes either omits the ui-review or treats the reviewer as any regular reviewer:

https://hg.mozilla.org/integration/fx-team/rev/c66c3620de84
https://hg.mozilla.org/integration/fx-team/rev/85bd262e7094

And sometimes it goes a little nutty:

https://hg.mozilla.org/integration/fx-team/rev/84df75fc0206

The link it produces dies:

https://hg.mozilla.org/integration/fx-team/log?rev=reviewer%28ui-%29&revcount=50

and I don't understand how to make it work locally so I don't know how often this happens.

Either way, it shouldn't do that. I don't really care which of the other options gets used (probably treating it as r= makes the most sense) but this is clearly wrong.
(Reporter)

Updated

3 years ago
Blocks: 1171321

Comment 1

3 years ago
Being addressed in bug 1221999.

Updated

3 years ago
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1221999
You need to log in before you can comment on or make changes to this bug.