Session Management disarranges windows/desktops on session restore

UNCONFIRMED
Unassigned

Status

()

Firefox
Session Restore
UNCONFIRMED
2 years ago
2 years ago

People

(Reporter: Hans-Peter Jansen, Unassigned)

Tracking

41 Branch
x86_64
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

2 years ago
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:41.0) Gecko/20100101 Firefox/41.0
Build ID: 2015101500

Steps to reproduce:

First of all, I'm using firefox on openSUSE KDE desktops since the beginning, and I still prefer it over the alternatives. Thank you for this great product. And I'm stressing it - literally. My usual setup is about 30 windows with about 300 tabs in total.

Due to this somewhat pathological use case, there's a nagging issue, that appears from time to time (update to update) - the session management seems to be unable to save the session in a way, that avoids the "Firefox crashed" dialog on startup - this behaviour persists since ages. This report is all about the result of hitting "restore session". 



Actual results:

The windows are restored on the right screens with the right dimensions, but more often than not, the content is mixed up: _all_ the tabs of one window appear in another, so it looses the relationship of the window content and its original location.


Expected results:

While I understand, that version upgrades may result in this behaviour, I expect, that the content of each window to appear in its original location, between upgrades.

It's really nagging to resize and relocate more that 15 of 30 windows on every restore.

This behaviour persists since Ff 4* at least, using Firefox 41.0.2 by now. Ff 1* and 2* did suffer from similar or even uglier session restore issues, 3* did mostly well in this regard.
Component: Untriaged → Session Restore
(Reporter)

Updated

2 years ago
OS: Unspecified → Linux
Hardware: Unspecified → x86_64

Comment 1

2 years ago
Hans-Peter, Is this different somehow from bug 842170?
(Reporter)

Comment 2

2 years ago
Yes, it is. Ff session restore behave differently, if stopped by user directly (^Q), and stopped by window manager. https://bugzilla.mozilla.org/show_bug.cgi?id=842170 is about the former, this one is about the latter.

Comment 3

2 years ago
(In reply to Hans-Peter Jansen from comment #2)
> Yes, it is. Ff session restore behave differently, if stopped by user
> directly (^Q), and stopped by window manager.
> https://bugzilla.mozilla.org/show_bug.cgi?id=842170 is about the former,
> this one is about the latter.

So you are saying the z-order of your windows is always correct if you have stopped firefox using ^Q?
And never 100% correct if the window manager is stopped?

It would be good to make this clear/explicit in the bug summary
Flags: needinfo?(hpj)
(Reporter)

Comment 4

2 years ago
@Wayne, could you briefly explain, what the term "z-order" means in this scenario?

For the last couple of reboots, I have the pleasure to inform you, that Firefix 41.0.2 on my openSUSE 13.2/x86_64 managed to restore the session exactly, how I left it. It still goes through the recovery manager, but anyway, this is a great success. I don't have to rearrange my ~30 windows.

Please keep this behaviour, that is found in 41.0.2.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Flags: needinfo?(hpj)
Resolution: --- → WORKSFORME

Comment 5

2 years ago
"When two windows overlap, their Z-order determines which one appears on top of the other." 
In other words, the order of the windows from front to back.
https://en.wikipedia.org/wiki/Z-order
HTH

> Please keep this behaviour, that is found in 41.0.2.
I don't know what changed it.  But a problem can be fixed, and reappear again for a different reason. So you might see the behavior reappear.
(Reporter)

Comment 6

2 years ago
After a couple of hard Firefox crashes, all windows are mixed up again, but not in z-order, therefore I reopen it again. In fact, z-order is the least, I care about, since I almost avoid overlapping Firefox windows by using the window shutter function of KDE4 (assigned to double click on window handle bar).

When using 300-400 tabs in 30-40 windows, you organize windows by topic on different desktops. If window location/desktop is all mixed up, you have to go to every window on every desktop, and push it to the correct place. You will have to do this, whenever you restart Firefox. Be assured, that such a procedure is, what heavy Firefox users with a similar working models want to avoid. I guess, that Firefox lost some of its heaviest users due to this problem. 

For reference, here's one of the earliest reported bugs in this respect: https://bugzilla.mozilla.org/show_bug.cgi?id=372650

Could some brave soul point me to the location, where Firefox remembers desktop and location of each window? I guess, this is part of some database file. I guess, we need to start with investigating this.
Status: RESOLVED → UNCONFIRMED
Resolution: WORKSFORME → ---
You need to log in before you can comment on or make changes to this bug.