Closed Bug 1220842 Opened 4 years ago Closed 4 years ago

Disable AuralProgressBar Temporarily

Categories

(Firefox for iOS :: General, defect)

Other
iOS
defect
Not set

Tracking

()

RESOLVED FIXED
Tracking Status
fxios 1.2+ ---

People

(Reporter: st3fan, Assigned: st3fan)

References

Details

Attachments

(1 file)

There are a number of problems with the AuralProgressBar that need more time be properly resolved. The large one is that it stays active when the app is in the background. We have a patch for that now, but confidence levels are not super high.

There are also other issues that we would like to resolve like making the APB better compatible with tab and application lifecycles. For example when switching tabs, the audio progress does not update. And when switching the app to the background, the progress audio keeps playing.

Some of these are regressions due to other audio changes we've made, like the background mode.

I would like to suggest to disable the APB for now and get it back in 2.0 when we have a better feeling about it.
Assignee: nobody → sarentz
This patch disables the use of the AuralProgressBar. Until we have figured out how to manage its background usage better.
Attachment #8682634 - Flags: review?(rnewman)
Attachment #8682634 - Flags: review?(bnicholson)
Status: NEW → ASSIGNED
Attachment #8682634 - Flags: review?(rnewman) → review+
Status: ASSIGNED → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Attachment #8682634 - Flags: review?(bnicholson)
See Also: → 1225749
I wish this would have been communicated in the release notes for 1.2. VoiceOver users view this as a regression on our part.
You need to log in before you can comment on or make changes to this bug.