NULL deref in [@GetDownloadDirectory]

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
3 years ago
9 months ago

People

(Reporter: tsmith, Unassigned)

Tracking

unspecified
x86_64
Linux
Points:
---

Firefox Tracking Flags

(firefox45 affected)

Details

Attachments

(2 attachments)

(Reporter)

Description

3 years ago
Created attachment 8682175 [details]
call_stack.txt

This is triggered by a drag and drop of a file. It seems to be dependent on the file extension not the contents of the file.

To reproduce:
Open Firefox (tested with 44 on Ubuntu 14.04)
Drag and drop file into the browser window
Browser then crashes

Expected result:
Prompt to download file or playback if the file type is supported.

I can reproduce this will an empty file with .au .3gp or .3g2 as the file extension.
(Reporter)

Comment 1

3 years ago
Created attachment 8682178 [details]
test.au

Updated

2 years ago
Component: File Handling → File Handling
Product: Core → Firefox
Version: Trunk → unspecified
(Reporter)

Updated

9 months ago
Status: NEW → RESOLVED
Last Resolved: 9 months ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.