browser crashes when loading page with flash plugin enabled.

VERIFIED DUPLICATE of bug 58937

Status

External Software Affecting Firefox
Flash (Adobe)
P2
critical
VERIFIED DUPLICATE of bug 58937
17 years ago
2 years ago

People

(Reporter: Pavel, Assigned: serge (gone))

Tracking

({crash, topcrash})

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.8+) Gecko/20020127
BuildID:    2002012706

When loading page news.walla.co.il browser crashes. Does not crash without flash
plugin. Does not crash in windows.

Reproducible: Always
Steps to Reproduce:
1.Load page news.walla.co.il or now.nana.co.il



Actual Results:  Browser crashes

Expected Results:  Load page

Talkback ID: TB2173278Z
If you're using a gcc3 mozilla build, this is a duplicate of bug 91470

Comment 2

17 years ago
WFM 2002012605-0.9.8/WinNT4. Flash plugin NPSWF32.dll version 5.0r41.

Comment 3

17 years ago
Stephen: can you pull TB2173278Z ?

(Reporter)

Comment 4

17 years ago
I'm using downloaded nightly build, so I don't know if it is gcc3 or not.
Btw, I'm using RedHat 7.1 and Mandrake 8.1.
libpthread.so.0 + 0x7cc7 (0x40207cc7)
libc.so.6 + 0x80d88 (0x4055cd88) 

Comment 6

17 years ago
--> serge
Assignee: av → serge

Comment 7

16 years ago
Pavel, is this still a problem with a recent build (or even 0.9.9)?

Did the file you download from mozilla.org contain 'gcc30' in its name?

Comment 8

16 years ago
swear to god, loading this page just clsoed my browser..but only once. My linux 
box was idle for hours before I entered this url and boom. browser just closed.
no talkack...
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 9

16 years ago
I just crashed on this page as well.
(I can't use flash since I build mozilla under gcc3 *grumble* *grumble*)

1. Go to the page.
2. Shift+Reload
3. Try switching to other windows.
4. If no crash, open the window with the site and repeat 2 again.
you'll eventually crash

Comment 10

16 years ago
Created attachment 79731 [details]
stack trace for your viewing pleasure
(Assignee)

Comment 11

16 years ago
no crash for me with rh7.2 debug build 20020414,
and I see nothing plugin related in the stack trace attachment 79731 [details]
(Assignee)

Comment 12

16 years ago
the stack trace attachment 79731 [details] looks similar to stack trases 
reported for bug 120639. 

Comment 13

16 years ago
I'm running mozilla that I built today from the trunk.
So I'm pretty sure it can't be that bug exactly ...
(Assignee)

Comment 14

16 years ago
just try to compare the stack traces.

Comment 15

16 years ago
you're right. almost the same thing.
maybe related to bug 127609?
(Assignee)

Comment 16

16 years ago
I cannot reproduce the crash with fresh installed 20002041715 optimized build,
neither in my 3 days old debug one, but if you can reliably reproduce the crash 
with such stack I would recommend to add this url to bug 127609 as a test case.
(Reporter)

Comment 17

16 years ago
I tried this page with mozilla 0.9.9 and build 2002041721. Mozilla 0.9.9 still
crashes on this page, but build 2002041721 does not. I'm not using gcc3 build.
B.t.w browser stops responding and eats 100% CPU when I tried to exit browser or
to load different page after loading this one.

Comment 18

16 years ago
Well. bug 127609 is now a dupe of bug 120639 ...

Comment 19

16 years ago
This crash might be related to bug 120639, but let's keep it open for these
newer crashes.  There have been a few crashes with this stack signature reported
by Talkback...all of them mention caranddriver.com:

Incident 5163822 - 
    Comments: www.caranddriver.com
Incident 5174858 - 
    Comments: caranddriver.com buyer's guide
Incident 5195479 - 
    URL: www.caranddriver.com
    Comments: xml page
Incident 5227793 - 
Incident 5322220 - 
    URL: caranddriver.com
Incident 5322265 - 
    URL: caranddriver.com

Those were all on Windows.  Then there was one incident from serge on Linux:
 Incident ID 5347327   
Stack Signature  nsImageListener::FrameChanged() 18c9a89c
Trigger Time 2002-04-17 21:41:09
Email Address serge@netscape.com
URL visited
Build ID 2002041715
Product ID MozillaTrunk
Platform
Operating System LinuxIntel
Module
Trigger Reason SIGSEGV: Segmentation Fault: (signal 11)
User Comments crahs while I left it running overnight
Stack Trace
nsImageListener::FrameChanged()
imgRequestProxy::FrameChanged()
imgRequest::FrameChanged()
imgContainer::Notify()
nsTimerImpl::Fire()
handleTimerEvent()
PL_HandleEvent()
PL_ProcessPendingEvents()
nsEventQueueImpl::ProcessPendingEvents()
event_processor_callback()
our_gdk_io_invoke()
libglib-1.2.so.0 + 0xff9e (0x4037ff9e)
libglib-1.2.so.0 + 0x11773 (0x40381773)
libglib-1.2.so.0 + 0x11d39 (0x40381d39)
libglib-1.2.so.0 + 0x11eec (0x40381eec)
libgtk-1.2.so.0 + 0x94333 (0x4029c333)
nsAppShell::Run()
nsAppShellService::Run()
netscape-bin + 0x8c79 (0x08050c79)
netscape-bin + 0x9457 (0x08051457)
libc.so.6 + 0x1c507 (0x404d6507) 

Vadim:  Can you try to reproduce this on caranddriver.com with your latest
build...and possibly try to reproduce your original crash with a recent nightly
Talkback enabled build?

Adding crash, topcrash keywords and  Trunk [@ nsImageBoxListener::FrameChanged]
to summary for tracking.
Keywords: crash, topcrash
Summary: browser crashes when loading page with flash plugin enabled. → browser crashes when loading page with flash plugin enabled. - Trunk [@ nsImageBoxListener::FrameChanged]

Comment 20

16 years ago
What does talkback give you that my stack trace does not ... ?
I build frm CVS so I don't have talkback but if you wish, I'll download a talk
enabled build to test.
(Assignee)

Comment 21

16 years ago
As I've posted above the stack traces with nsImageBoxFrame::FrameChanged()
have no  plugin related calls at all, but this bug was open because mozilla 
crashed when flash plugin is installed.
Vadim's stack trace got here only because he crashed on test url from this bug 
report:( According to Vadim's stack, the talkback IDs (my incident ID 5347327, I 
crashed w/o flash plugin, I've just left the page open overnight) the fix for 
bug 135222 did not eliminate crashes in nsImageBoxFrame::FrameChanged() 
completely.
jpatel, please reopen bug 120639 or bug 120639 and add http://news.walla.co.il 
as a test case, at least those bugs have the right owner.

Comment 22

16 years ago
Sorry.
Ok .. I crashed on caranddriver.com and have a stack trace.
Please reopen one of those bugs, or open a new one so that I have a place I can
post the trace ...

Comment 23

16 years ago
Serge:  I'll just open a new bug for the recent crashes.  Yes, the fix for bug
135222 clearly didn't eliminate all of the crashes in
nsImageBoxListener::FrameChanged, but since bug 120639 was mostly about the
spike in crashes, I'm going to leave it alone.  I will also leave this bug
alone...sorry for the confusion.
(Assignee)

Comment 24

16 years ago
thanks Jay.
indeed, caranddriver.com is a reliable test case for crash in 
nsImageBoxFrame::FrameChanged
Summary: browser crashes when loading page with flash plugin enabled. - Trunk [@ nsImageBoxListener::FrameChanged] → browser crashes when loading page with flash plugin enabled.

Comment 25

16 years ago
Logged new bug 138292 for non-plugin related crashes in
nsImageBoxListener::FrameChanged.  

Removing Trunk [@ nsImageBoxListener::FrameChanged] from summary.

Comment 26

16 years ago
What is to be done with this bug?
(Assignee)

Comment 27

16 years ago
repro test case not related to the crash in nsImageListener::FrameChanged()
is needed here.

Comment 28

16 years ago
The browser always crashes immediately when loading pages containing Flash
animations, such as http://news.walla.co.il or http://www.haaretz.co.il when
running on HP-UX 11.00 (User agent: Mozilla/5.0 (X11; U; HP-UX 9000/780; en-US;
rv:1.0rc1) Gecko/20020418)

Comment 29

16 years ago
putting into 1.0.1
Priority: -- → P2
Target Milestone: --- → mozilla1.0.1

Updated

16 years ago
Summary: browser crashes when loading page with flash plugin enabled. → browser crashes when loading page with flash plugin enabled.

Comment 30

16 years ago
I can confirm this bug. The problem occurs under Linux only, Windows is alright
and displays flash-animations successfully. If you use the plugin under Linux,
that works quite fine in Konqueror for example, Mozilla hangs/freezes when
visiting a flash-animated web-site. It doesn't crash and therefore the talkback
daemon is not being activated.
Status: NEW → ASSIGNED
(Assignee)

Comment 31

16 years ago
Stephan Marwedel: for hpux plugins support see bug 51376
Phil: for possible linix flash plugin hangs 
if some audio is playing see bug 58339
I cannot reproduce the crash on http://news.walla.co.il.
Reporter, could you test the latest mozilla build please?
(Reporter)

Comment 32

16 years ago
It looks that in latest builds browser doesn't crash on news.walla.co.il when
run on local display. It still crashes there when run on remote display - I
think it's a known problem listed on release notes for latest releases. 
(Assignee)

Comment 33

16 years ago
in this case this one is a dup of 58937

*** This bug has been marked as a duplicate of 58937 ***
Status: ASSIGNED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE

Comment 34

16 years ago
v
Status: RESOLVED → VERIFIED

Updated

8 years ago
Component: Plug-ins → Flash (Adobe)
Product: Core → Plugins
QA Contact: shrir → adobe-flash
Target Milestone: mozilla1.0.1 → 2002
Version: Trunk → 5.x

Comment 35

2 years ago
Version and milestone values are being reset to defaults as part of product refactoring.
Target Milestone: 2002 → ---
Version: 5.x → unspecified
You need to log in before you can comment on or make changes to this bug.