migrate Bluetooth to use NotificationHelper

RESOLVED FIXED in Firefox OS master

Status

Firefox OS
Gaia::Bluetooth
RESOLVED FIXED
2 years ago
2 years ago

People

(Reporter: heidi.kasemir, Assigned: heidi.kasemir, Mentored)

Tracking

unspecified
FxOS-S11 (13Nov)
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(b2g-master fixed)

Details

Attachments

(1 attachment)

(Assignee)

Description

2 years ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_11_1) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/46.0.2490.80 Safari/537.36

Comment 1

2 years ago
Created attachment 8682324 [details] [review]
[gaia] hkasemir:1220978-Bluetooth-notificationhelper > mozilla-b2g:master
Assignee: nobody → heidi.kasemir
Blocks: 1111841
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Summary: migrate bluetooth to use NotificationHelper → migrate Bluetooth to use NotificationHelper
Attachment #8682324 - Flags: review?(gandalf)
Comment on attachment 8682324 [details] [review]
[gaia] hkasemir:1220978-Bluetooth-notificationhelper > mozilla-b2g:master

Shawn, I got a new hacker helping me with bug 1111841 which will make our notifications l10n aware.
The tests are green.

Can you review this?
Attachment #8682324 - Flags: review?(shuang)
Comment on attachment 8682324 [details] [review]
[gaia] hkasemir:1220978-Bluetooth-notificationhelper > mozilla-b2g:master

Hi Fred,
This looks like your area. Can you review this patch?
Attachment #8682324 - Flags: review?(shuang) → review?(gasolin)
Attachment #8682324 - Flags: review?(gandalf) → review+

Comment 4

2 years ago
Comment on attachment 8682324 [details] [review]
[gaia] hkasemir:1220978-Bluetooth-notificationhelper > mozilla-b2g:master

looks good except 2 nits about trailing spaces
Attachment #8682324 - Flags: review?(gasolin) → review+
Heidi, when you have a chance, please, apply Fred's feedback, squash your commits into a single one[*] and put 'checkin-needed' in keywords. Thank you!


[*] http://gitready.com/advanced/2009/02/10/squashing-commits-with-rebase.html
Mentor: gandalf@aviary.pl
(Assignee)

Updated

2 years ago
Keywords: checkin-needed

Updated

2 years ago
Duplicate of this bug: 1128806
https://github.com/mozilla-b2g/gaia/commit/f3c4a0f7ff031a836e69f7463df44e92313bf12a
Status: ASSIGNED → RESOLVED
Last Resolved: 2 years ago
status-b2g-master: --- → fixed
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → FxOS-S11 (13Nov)

Comment 8

2 years ago
Not sure if related, but sometimes I got log error with the following steps

1. choose a image to share in gallery
2. select bluetooth
3. got log error `L10nError: Context not ready`
Flags: needinfo?(gandalf)
It shouldn't be. The only thing that I know that causes this error is use of mozL10n.get and in this bug we just removed a bunch of those calls :)

There are still 31 calls to mozL10n.get in bluetooth and I plan to remove them in this cycle, that should get rid of this message since all other APIs are async are non-racy.

If you want to find what causes it, go to shared/js/l10n.js, line 1370 and add "var e = new Error(); console.log(e.stack);".

This will tell you where mozL10n.get has been called from and this place is probably called before mozL10n is ready (you need to wrap it in mozL10n.once)
Flags: needinfo?(gandalf)

Comment 10

2 years ago
Thanks for insight :)
You need to log in before you can comment on or make changes to this bug.