Closed Bug 1220996 Opened 7 years ago Closed 7 years ago

Catch before/after key events for non-mozbrowser iframes in smart-system

Categories

(Firefox OS Graveyard :: Gaia::TV::System, defect, P3)

ARM
Gonk (Firefox OS)
defect

Tracking

(b2g-v2.5 verified, b2g-master verified)

VERIFIED FIXED
FxOS-S11 (13Nov)
Tracking Status
b2g-v2.5 --- verified
b2g-master --- verified

People

(Reporter: cynthiatang, Assigned: yifan)

References

Details

(Whiteboard: [ft:conndevices][partner-cherry-pick])

Attachments

(1 file)

commit f17421e9a23b9dbd88c41347f1b9c442a97f48e0
Merge: 06de78d e7dd557
Author: gasolin <gasolin@gmail.com>
Date:   Tue Nov 3 13:37:26 2015 +0800

STR:
 1. Launch Browser
 2. Go to Browser Setting
 3. Select Sign in to Sync and press OK
 4. Press Home 

Actual Result:
 - The user cannot go back to home screen

Expected Result:
 - The user can go back to home screen
QA Whiteboard: [COM=TV Firefox Account]
This is probably because we are not handling the HOME key on the FxA flow. YiFan, could you take a look at this, please?
Flags: needinfo?(yliao)
Blocks: fxos-sync
Priority: -- → P3
Target Milestone: --- → FxOS-S11 (13Nov)
Yes, thank you for noticing this!
Assignee: nobody → yliao
Status: NEW → ASSIGNED
Flags: needinfo?(yliao)
According to https://bugzilla.mozilla.org/show_bug.cgi?id=1014418#c32 , the smart-system needs the 'before-after-keyboard-event' permission to catch home button press on a non-mozbrowser iframe.
Component: Gaia::TV::Browser → Gaia::TV::System
See Also: → 1014418
Summary: [TV Browser] User cannot go to Home screen from the Firefox Account - Sign in page → Catch before/after key events for non-mozbrowser iframes in smart-system
Attachment #8683497 - Flags: review?(rexboy)
Comment on attachment 8683497 [details] [review]
[gaia] begeeben:1220996_user_cannot_go_to_home > mozilla-b2g:master

Looks good to me.
Attachment #8683497 - Flags: review?(rexboy) → review+
https://github.com/mozilla-b2g/gaia/commit/d9e3e3bc529221db6793cb9b116059070a65a287
Status: ASSIGNED → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Comment on attachment 8683497 [details] [review]
[gaia] begeeben:1220996_user_cannot_go_to_home > mozilla-b2g:master

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): 1194108
[User impact] if declined: Pressing back key on the remote control will has no effect at certain dialogs.
[Testing completed]: https://treeherder.mozilla.org/#/jobs?repo=gaia&revision=7281c8685773bb354bbbb8037eede00d4ec22954
[Risk to taking this patch] (and alternatives if risky): none
[String changes made]: none
Attachment #8683497 - Flags: approval-gaia-v2.5?
Comment on attachment 8683497 [details] [review]
[gaia] begeeben:1220996_user_cannot_go_to_home > mozilla-b2g:master

Approved to uplift to 2.5

Thanks
Attachment #8683497 - Flags: approval-gaia-v2.5? → approval-gaia-v2.5+
Whiteboard: [ft:conndevices] → [ft:conndevices][partner-cherry-pick]
Blocks: 1230588
You need to log in before you can comment on or make changes to this bug.