[PP][CRASH] Win32, Mac: Backspace crashes in Location control

VERIFIED DUPLICATE of bug 12226

Status

()

Core
Layout: Form Controls
P3
major
VERIFIED DUPLICATE of bug 12226
19 years ago
19 years ago

People

(Reporter: cpratt, Assigned: joki (gone))

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

19 years ago
Build ID: 1999082008
Platform: Mac OS 8.6, Windows NT (Linux seems OK)

To reproduce:
- Launch apprunner
- Click into the Location: control
- Press Backspace

Note: it may be necessary to this several times in order to crash. On the Mac,
it happens to me quickly; it takes longer on Windows.

Result: a crash.

Expected result: no crash.

A talkback report was generated:
http://cyclone/reports/incidenttemplate.CFM?reportID=124&style=0&tc=4&cp=1&ck1=S
User+email+address&cd1=%25bear%40marmot%2Enet%25&co1=like&bbid=12657856

Updated

19 years ago
Assignee: trudelle → buster

Comment 1

19 years ago
not our widget, reassigning to buster, cc kmcclusk
(Reporter)

Comment 2

19 years ago
The forward delete (DELETE) key also crashes badly for me using Win32.

Updated

19 years ago
Assignee: buster → joki
Component: XP Toolkit/Widgets → HTML Form Controls
Depends on: 12226

Comment 3

19 years ago
this is related to, or the same as, 12226 submitted by rods. His report is more
detailed, it seemed specifically to be related to backspacing in the text
control while a document was loading in the content area. I don't see the editor
code anywhere on the stack, either in this talkback report or debugging with
rods.
(Assignee)

Updated

19 years ago
Status: NEW → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → DUPLICATE
(Assignee)

Comment 4

19 years ago
I agree, I think this is the same at 12226 which was fixed.  I'm going to dupe
it but if it can be reproduced, please provide instructions (as I can't repro
this) and reopen.

*** This bug has been marked as a duplicate of 12226 ***
(Reporter)

Updated

19 years ago
Status: RESOLVED → VERIFIED
(Reporter)

Comment 5

19 years ago
Marking as verified duplicate (of a newer bug!).
You need to log in before you can comment on or make changes to this bug.