Repeated image 'loads' in javascript will leak memory until mozilla is closed

RESOLVED DUPLICATE of bug 127825

Status

()

Core
ImageLib
RESOLVED DUPLICATE of bug 127825
16 years ago
16 years ago

People

(Reporter: Ron, Assigned: Stuart Parmenter)

Tracking

Trunk
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
 
(Reporter)

Comment 1

16 years ago
If you keep track of the memory usage of mozilla you can see it grow
dramatically when you press on the left or right arrow ( this moves you left or
right throught the slide show and thus loads additional images ) The javascript
engine forgets to release the old image that was assigned to the Img variable.
Summary: Repeated 'loads → Repeated image 'loads' in javascript will leak memory until mozilla is closed
(Reporter)

Comment 2

16 years ago
Corrected the link. (sorry about that)

Comment 3

16 years ago
Browser, not engine ---> ImageLib
Assignee: rogerl → pavlov
Component: JavaScript Engine → ImageLib
QA Contact: pschwartau → tpreston

Comment 4

16 years ago

*** This bug has been marked as a duplicate of 127825 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.