SkASSERTF(fRefCnt == 1, "fRefCnt was %d", fRefCnt); at gfx/skia/skia/include/core/SkRefCnt.h:40

RESOLVED WONTFIX

Status

()

RESOLVED WONTFIX
3 years ago
2 years ago

People

(Reporter: gwagner, Assigned: sotaro)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [gfx-noted])

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
Created attachment 8682536 [details]
gdb

Seen on current tip on aries device with debug gecko during monkey testing (sending random input events to device)
(Reporter)

Comment 1

3 years ago
(gdb) p fRefCnt
$1 = 4

Milan, any idea who knows this code?
Flags: needinfo?(milan)
Assignee: nobody → sotaro.ikeda.g
Flags: needinfo?(milan)
Whiteboard: [gfx-noted]
(Assignee)

Comment 2

3 years ago
:gwagner, is the crash reproducable? Can we also have a logcat log and dmesg log? Thanks.
Flags: needinfo?(anygregor)
(Assignee)

Comment 3

3 years ago
From attachment 8682536 [details], until stack #7 seems to be valid actually. It calls exit(). It means exit program. From it, the code failed to create EGLImage and tried to exit program.

> #7  0xb6eeae40 in exit (status=1) at bionic/libc/stdlib/exit.c:57
> #8  0xb21ad082 in ioctl_kgsl_sharedmem_map_fd () from /Volumes/disc2/aries/B2G/out/target/product/aries/system/vendor/lib/libgsl.so
> #9  0xb156a850 in ?? () from /Volumes/disc2/aries/B2G/out/target/product/aries/system/vendor/lib/egl/eglsubAndroid.so
> #10 0xb16ee160 in qeglDrvAPI_eglCreateImageKHR ()  from /Volumes/disc2/aries/B2G/out/target/product/aries/system/vendor/lib/egl/libEGL_adreno.so
> #11 0xb16e0f00 in eglCreateImageKHR () from /Volumes/disc2/aries/B2G/out/target/product/aries/system/vendor/lib/egl/libEGL_adreno.so
> #12 0xb6e20706 in eglCreateImageKHR (dpy=<optimized out>, ctx=0x0, target=12608, buffer=0xa59c6c88, attrib_list=0xa0b076b0) at frameworks/native/opengl/libs/EGL/eglApi.cpp:1390
> #13 0xb3766bce in fCreateImage (attrib_list=<optimized out>, buffer=0xa59c6c88, target=12608, ctx=0x0, dpy=0x1, this=<optimized out>) at ../../dist/include/GLLibraryEGL.h:370
> #14 mozilla::layers::EGLImageCreateFromNativeBuffer (aGL=aGL@entry=0x9dfdd000, aBuffer=0xa59c6c88, aCropSize=...) at /Users/gregor/moz/ib2g/gfx/layers/opengl/EGLImageHelpers.cpp:43
(Reporter)

Comment 4

3 years ago
(In reply to Sotaro Ikeda [:sotaro] from comment #2)
> :gwagner, is the crash reproducable? Can we also have a logcat log and dmesg
> log? Thanks.

Sorry I dont have STR. It happened during a long running monkey test session. I will try to get the logs next time.
Flags: needinfo?(anygregor)
(Assignee)

Comment 5

2 years ago
Without STR, it could not be reproducible.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.