Closed Bug 1221174 Opened 4 years ago Closed 3 years ago

"Share this page" popup doesn't display "plus" icon on HiDPI

Categories

(Firefox :: Theme, defect)

40 Branch
defect
Not set

Tracking

()

VERIFIED FIXED
Firefox 51
Tracking Status
firefox45 --- wontfix
firefox47 --- wontfix
firefox48 --- wontfix
firefox49 --- verified
firefox-esr45 --- wontfix
firefox50 --- verified
firefox51 --- verified

People

(Reporter: arni2033, Assigned: jaws)

References

(Blocks 1 open bug)

Details

(Keywords: regression)

Attachments

(3 files)

STR:   (Win7_64, Nightly 45, 32bit, ID 20151102030241, new profile)
1. Set DPI in your OS -> 125% or set layout.css.devPixelsPerPx -> 1.25 in firefox
2. Right-click australis menu button (≡), click Customize, move "Share this page" button to toolbar
   Exit customize
3. Click "Share this page" button on this page

Result:       There's no "Plus" icon
Expectations: There should be "Plus" icon, just like on normal DPI
Blocks: win-hidpi
This is regression from bug 1153309 (presumably). Regression range:
> https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=baa9c64fea6f&tochange=f986e55c4e0b
Blocks: 1153309
Has Regression Range: --- → yes
Has STR: --- → yes
Keywords: regression
Version: Trunk → 40 Branch
This is Windows-only; wfm on OS X Retina but is broken on my Surface Pro.

I'd guess this is actually from bug 1023607 or bug 1168528?
Flags: needinfo?(jaws)
Assignee: nobody → jaws
Status: NEW → ASSIGNED
Flags: needinfo?(jaws)
Comment on attachment 8781355 [details]
Bug 1221174 - Define the HiDPI version of Share's add-share-button for all themes.

https://reviewboard.mozilla.org/r/71788/#review69532
Attachment #8781355 - Flags: review?(dolske) → review+
https://hg.mozilla.org/mozilla-central/rev/55c7a30fb05c
Status: ASSIGNED → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 51
Jared, do you want to uplift that to 49 & 50? Thanks
Approval Request Comment
[Feature/regressing bug #]: bug 1153309
[User impact if declined]: button missing icon in the Share panel
[Describe test coverage new/current, TreeHerder]: manual testing, verified locally on aurora and beta builds
[Risks and why]: none
[String/UUID change made/needed]: none
Flags: needinfo?(jaws)
Attachment #8783695 - Flags: approval-mozilla-beta?
Attachment #8783695 - Flags: approval-mozilla-aurora?
Comment on attachment 8783695 [details] [diff] [review]
Patch for aurora50 and beta49

Thanks, let's take that in aurora and beta. Should be in 49 beta 7.
Attachment #8783695 - Flags: approval-mozilla-beta?
Attachment #8783695 - Flags: approval-mozilla-beta+
Attachment #8783695 - Flags: approval-mozilla-aurora?
Attachment #8783695 - Flags: approval-mozilla-aurora+
Managed to reproduce this bug on Nightly 49.0a1 (2016-04-28) (Build ID: 20160428030218) on Linux.

This Bug's Fix is now verified on Latest Firefox Nightly 51.0a1 (2016-08-23)

Build ID: 20160823072522
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:51.0) Gecko/20100101 Firefox/51.0
OS: Linux 4.4.0-2-deepin-amd64
QA Whiteboard: [bugday-20160824]
I have reproduced this bug with Firefox Nightly 45.0a1 (Build ID: 20151103030248) on 
Windows 8.1, 64-bit.

Verified as fixed with Latest Firefox beta 49.0b7 (Build ID: 20160825132718)
Mozilla/5.0 (Windows NT 6.3; WOW64; rv:49.0) Gecko/20100101 Firefox/49.0

Verified as fixed with Latest Firefox Developer edition 50.0a2 (Build ID: 20160826004001)
Mozilla/5.0 (Windows NT 6.3; WOW64; rv:50.0) Gecko/20100101 Firefox/50.0

Verified as fixed with Latest Firefox Nightly 51.0a1 (Build ID: 20160825030226)
Mozilla/5.0 (Windows NT 6.3; WOW64; rv:51.0) Gecko/20100101 Firefox/51.0
QA Whiteboard: [bugday-20160824] → [bugday-20160824] [testday-20160826]
You need to log in before you can comment on or make changes to this bug.