Translation of "Spam" and "Archive" folders in Simple Chinese

RESOLVED INVALID

Status

RESOLVED INVALID
3 years ago
3 years ago

People

(Reporter: i, Assigned: shaohua.wen)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

3 years ago
Created attachment 8682626 [details]
imap-folder-name.png

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:41.0) Gecko/20100101 Firefox/41.0
Build ID: 2015101500

Steps to reproduce:

Here are some folders in my email have not been translated into Simple Chinese.

Archive -> 归档
Spam -> 垃圾

Other standard IMAP folders, like "Sent", "Drafts", are translated. I am not sure if "Spam" and "Archive" are standard folders, but Thunderbird detected them and set them as default folder of spams and archives.

I downloaded the source code archive of Thunderbird, but there is no Chinese translation files. It would be great to know how to join translation, so I will not bother too many times.

Thanks!
http://mxr.mozilla.org/l10n-central/search?string=Archive&find=%2Fzh&findi=&filter=^[^\0]*%24&hitlimit=&tree=l10n-central

But it looks to me archivesFolderName is translated.

See https://wiki.mozilla.org/L10n:Teams:zh-CN "How to join this team" for how to join the zh-CN translation team!
Assignee: nobody → shaohua.wen
Component: Mail Window Front End → zh-CN / Chinese (Simplified)
Product: Thunderbird → Mozilla Localizations
QA Contact: shaohua.wen
Version: 38 → unspecified

Comment 2

3 years ago
What is your e-mail service provider? These folder name works fine for my gmail.

Also, the related strings has been translated, and the "Spam" does not seem to exist a string.
https://transvision.mozfr.org/?recherche=Archive&repo=release&sourcelocale=en-US&locale=zh-CN&search_type=strings
Flags: needinfo?(guoyunhebrave)

Comment 3

3 years ago
Created attachment 8686467 [details]
imap gmail work fine
(Reporter)

Comment 4

3 years ago
Provider is https://fastmail.com/

I think Fastmail uses a different folder name from Gmail.

For "Spam", since there is no translation string, it will display the exact name of IMAP folder. Gmail's folder names are already translated on server side. So it shows translated folder names. Fastmail does not translate the name of IMAP folders on server side.

In Folder Subscription window, you can see the name of folders on IMAP server. For Gmail, it is in English. For Fastmail, it is in English.

http://i.imgur.com/I1eq9Wd.png

For "Archive", though a string is translated, but it is for different purpose: archiveButton.label. https://transvision.mozfr.org/?sourcelocale=en-US&locale=zh-CN&repo=release&search_type=entities&recherche=mail/chrome/messenger/multimessageview.dtd:archiveButton.label The "Archives" has a string: archiveFolderName https://transvision.mozfr.org/?sourcelocale=en-US&locale=zh-CN&repo=release&search_type=entities&recherche=mail/chrome/messenger/messenger.properties:archivesFolderName

So folder name handler does not process the folder name "Archive" to translation.
Flags: needinfo?(guoyunhebrave)

Comment 5

3 years ago
So, this is not a translation issue.

If you need a name converter (translator), fill an new bug or make an extension.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.