Backout Hello web sharing changes from 44

RESOLVED WONTFIX

Status

Hello (Loop)
Client
RESOLVED WONTFIX
2 years ago
2 years ago

People

(Reporter: Mardak, Assigned: Mardak)

Tracking

unspecified
mozilla44
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Assignee)

Description

2 years ago
We want to revert all of the new web sharing experience to go back to what it was in 43. 44 is currently in aurora. There were strings removed and new ones added for the new experience.

Here are changes since 43:

$ git log gecko/beta..gecko/aurora --format='format:> %h %s <%an>' --reverse browser/{base/content/browser-loop.js,components/loop,locales/en-US/chrome/browser/loop}

> ac52ffd Bug 1184940 - Implement the refreshed design for the edit context view [r=dmose] Additional patch for review comments. <Ed Lee>
> 6c175f8 Bug 1184924 - Implement the refreshed design for the invitation overlay strings [rs=dmose] Additional patch for localization note. <Ed Lee>
> 3dbec6a Bug 1205658 - Hello Spinner Blue should match other blue elements in Hello [r=Standard8] <Ed Lee>
> 0626884 Bug 1206701 - Fix the contact menu buttons on Loop's panel so that audio and video conversations can be selected properly. r=Mardak <Mark Banner>
> 871c8d7 Bug 1203298 - Room loading spinner should be vertically centered. r=Standard8 <Manuel Casas>
> efe328f Bug 912121 - Rewrite require / import to match source tree. rs=devtools <J. Ryan Stinnett>
> 760cad9 Bug 1199213 - Part 2. Remove the old css relating to standalone call-url handling from Loop. r=mikedeboer <Mark Banner>
> 90b5c39 Bug 1199213 - Part 3. More cleanup of conversation related css after call-url code removal. r=mikedeboer <Mark Banner>
> 731d6b0 Bug 1206457 - Fix intermittent browser_LoopRooms_channel.js time out, set up the back channel earlier to avoid loading time/setup issues. r=mikedeboer <Mark Banner>
> fb76537 Bug 1192924: Expose the update URL formatting code a new UpdateUtils module. r=rstrong <Dave Townsend>
> 468b697 Backed out 3 changesets (bug 1192924) for Android bustage CLOSED TREE <Wes Kocher>
> e35ad56 Bug 1205610 - Log the string associated with OT's UNABLE_TO_PUBLISH exception to help understand where it is coming from. r=Mardak <Mark Banner>
> a22c2d1 Bug 1192924: Expose the update URL formatting code a new UpdateUtils module. r=rstrong <Dave Townsend>
> f7c532a Bug 1188771 - Inform users when they can't use the Hello service due to ToS compliance. r=mikedeboer <Mark Banner>
> b3e8cd9 Bug 1208201 - Simplify setup flows for standalone and desktop in Loop's activeRoomStore. r=mikedeboer <Mark Banner>
> 29ef68c Bug 1207575 - Fix reporting of Loop's connection status if a user exits a room and then re-enters it without reloading the room. r=Mardak <Mark Banner>
> 94439fd Bug 1190738-Add Edit view with error to Hello ui-showcase, r=dmose <David Critchley>
> 04a1949 Bug 1208515 - The feedback view has the incorrect blue for the Hello icon and button. r=dmose <Mark Banner>
> 2f3bdad Bug 1209029 - .settings-menu .icon classes in Loop's panel are obsolete and should be removed. r=Standard8 <Mark Banner>
> 7488cc8 Bug 1193674 - If room context/name is unavailable, the title of the standalone is displayed as "{{roomName}} - Firefox Hello". r=Standard8 <Manuel Casas>
> 3c0a376 No bug. Fix Loop's eslint configuration, due to fallout from bug 1203520. rs=dmose NPOTB DONTBUILD <Mark Banner>
> 331a00a Merge m-c to fx-team, a=merge <Wes Kocher>
> 2020ebb Bug 1205206 - Move Loop Standalone Terms of Service text from footer to under Join button. r=Standard8 <David Critchley>
> b082fae Bug 1208466 - Part 1. Create a new ToS view for Loop's standalone, ready for integration into the handled-in-Firefox views. r=mikedeboer <Mark Banner>
> aaca92e Bug 1208466 - Part 2. If an owner of a Loop link clicks their own link and join, make it open the conversation window. r=mikedeboer <Mark Banner>
> 81cf28c Bug 1208466 - Part 3. Fix display when opening room, and make the opened room text non-bold. r=mikedeboer <Mark Banner>
> 1026ce2 Bug 1188509-Bundle Hello standalone JS for performance, r=Standard8 <Dan Mosedale>
> 0d7cc06 Bug 1208647-minify OpenTok+lodash for faster Hello standalone load time, r=Standard8 <Dan Mosedale>
> a1a700a Bug 1171962: introduce telemetry histogram that counts the amount of sessions that exchanged one or more chat messages. r=vladan,dmose <Mike de Boer>
> 218567c Bug 1209078 - Part 1. When detecting if rooms are able to be handled by Firefox, also include an indication if they are already open or not. r=mikedeboer <Mark Banner>
> 85a8eff Bug 1209078 - Part 2. If a user attempts to open their own room within Firefox when the room is already open, provide a message to inform the user. r=mikedeboer <Mark Banner>
> d872fdc Bug 1206457 - Second attempt to fix intermittent failure in browser_LoopRooms_channel.js - ensure previous states are cleared when they are used. r=mikedeboer <Mark Banner>
> afdaddf1 Bug 1155923 - Removing moz prefix from RTC interfaces, r=jesup,smaug <Martin Thomson>
> aaf1704 Bug 1209620 - Fix intermittent failure finding the start a conversation button in Loop's functional tests. r=dmose NPOTB DONTBUILD <Mark Banner>
> f5edfaa Bug 1204101 - Fix for Loop settings menu positioning where menu gets cropped from longer text, r=dmose <David Critchley>
> 8bdfaac Bug 1202265 - Add visual regression tool for Hello, r=dmose <Andrei Oprea>
> f1919b9 Merge mozilla-central to mozilla-inbound <Carsten "Tomcat" Book>
> 7c2b0c5 Merge inbound to central, a=merge <Wes Kocher>
> 1e28b26 Bug 1184924 - Implement the refreshed design for the invitation overlay [r=Standard8] <Ed Lee>
> 9933832 Bug 1118926 (Part 2) - Remove remnants of -moz-resolution in JavaScript code. r=dolske <Seth Fowler>
> 41a3783 Bug 1184921: allow custom buttons to be added to the chatbox titlebar and implement one for Hello that closes the window when clicked. r=Standard8 <Mike de Boer>
> 07ed19e merge mozilla-inbound to mozilla-central a=merge <Carsten "Tomcat" Book>
> 6db5f58 Merge m-c to fx-team <Carsten "Tomcat" Book>
> 1fb1bc7 Bug 1210331 - Clean up strings for conversations panel and conversation invite [r=Standard8] <Ed Lee>
> 34bf33b Bug 1207300 - If Firefox is started offline, then Loop never initialises correctly. r=dmose <Mark Banner>
> 044d170 Bug 1204343 - Loop's accept call buttons has different heights and looks strange. r=mikedeboer <Mark Banner>
> f9f09d3 Bug 1209592 - Fix Loop's screenshare dropdown being misplaced on large window sizes. r=mikedeboer <Mark Banner>
> 6778068 Bug 1210513 - Loop's direct calls don't cancel properly if you click the hangup button on the toolbar. r=mikedeboer <Mark Banner>
> 11f3927 Bug 1106932 - allow opening the loop panel from the menu, focus the panel immediately, r=mikedeboer <Gijs Kruitbosch>
> 2236535 Bug 1204345 - Last letter at bottom right can be cut off, r=dmose <Chris Rafuse>
> 45b716e Bug 1210707 - Feedback view no longer allows closing the window and avoiding leaving feedback. r=mikedeboer <Mark Banner>
> 8de4feb Bug 1172662 - ICE failures occuring in Loop conversations should be reported to the user. r=Standard8 <Manuel Casas>
> 52e365b Bug 1202902 - Fix the world. (r=ato for marionette, rs=Mossop for rest) <Shu-yu Guo>
> d06b603 Bug 1202902 - Scripted fix the world. <Shu-yu Guo>
> e7ef778 Backed out 1 changesets (bug 1202902) for causing merge conflicts to mozilla-central <Carsten "Tomcat" Book>
> a06648db Bug 1208047 - Close the dropdown menu for sharing on Loop's conversation window as soon as an item is clicked, rather than leaving it open in a potentially confusing state. r=mikedeboer <Mark Banner>
> 0709540 Bug 1211592 - The Copy Link and Email Link buttons show cursor:default, but the other buttons (Camera,Mic,Share Screen,Settings) show cursor:pointer [rs=jaws] <Ed Lee>
> 22dc1b2 Bug 1211563 - Invite buttons should be underneath "Invite a friend" text in popped-out view [r=Standard8] <Ed Lee>
> cdcff6d Backed out changeset c6b267589d0d (bug 1202902) for Mulet Reftest, W3C Platform Test and other failures. r=backout a=backout on a CLOSED TREE <Sebastian Hengst>
> 0899700 Backed out 2 changesets (bug 1202902) to recking bug 1202902 to be able to reopen inbound on a CLOSED TREE <Carsten "Tomcat" Book>
> 399a23b Merge inbound to m-c a=merge <Wes Kocher>
> 219eacc Bug 1212272 - 'make dist' for the Loop standalone doesn't update the css and supplementary files properly. r=dmose. NPOTB DONTBUILD <Mark Banner>
> c23069f Merge m-c to fx-team a=merge <Wes Kocher>
> 310ba9b Bug 1209632 - Removing footer from Loop Standalone, moved Logo to mediaLayoutView. r=Standard8,ui-review=Sevaan <David Critchley>
> d6efa38 Bug 1200693 - Modify aspect ratio so that top and bottom black bars are not seen when waiting alone in the conversation window. r=Standard8 <Manuel Casas>
> 4e0f930 Bug 1212074 - Remove the tabs from Loop's panel. r=Standard8 <David Critchley>
> bc83c52 Bug 1212074 - Update Mochitests for Loop now that the tabs are removed from the panel. r=mikedeboer <Mark Banner>
> 93963ee Bug 1212348 - Loop's RoomList view requires user profile data passed in when it doesn't need to. r=mikedeboer <Mark Banner>
> ae5c215 Follow-up to bug 1212272 - use the correct cp command. r=dmose <Mark Banner>
> 484a185 Bug 1212787 - Revert Loop's conversation toolbar button sizes due to bug 1209632 causing a visual regression. r=dmose <Mark Banner>
> 19d46ca Bug 1213213 - run-all-loop-tests.sh isn't catching all mochitest failures. r=mikedeboer <Mark Banner>
> 5959ef0 Bug 1212083 - Part 1. Remove the direct calls UI from Loop. r=mikedeboer <Mark Banner>
> 4231bf3 Bug 1212083 - Part 2. Remove the unused files previously associated with direct calls. r=mikedeboer <Mark Banner>
> 85db519 Bug 1201308 - Leave / Exit conversation button always present, r=dmose <Chris Rafuse>
> ce20cde Bug 1212338 - Move the user's "availability" option to the settings menu as a "turn notifications on/off" in the Loop panel. r=Standard8 <Manuel Casas>
> 0a27b3e Bug 1212331 - Remove the Let's talk about context addition options from the Loop panel. r=Standard8 <Manuel Casas>
> 8910f19 Bug 1209589 - Collect Google Analytics data for users on IE 10 & 11. r=Standard8 <Chris Rafuse>
> e60145f Bug 1212340 - Move the Leave feedback option from the conversation window settings menu to the panel settings menu. r=Standard8 <Manuel Casas>
> 89cb263 Bug 1204812 - Keep Console.jsm in toolkit/modules/ r=jryans,Mossop <Alexandre Poirot>
> 178ba2f Bug 1212361 - Re-arrange panel layout for user journey (put the button above the room list) [r=Standard8] <Ed Lee>
> e0db1b6 Bug 1213810 - Remove obsolete actions previously associated with direct calls. r=mikedeboer <Mark Banner>
> 3539ee9 Bug 1213855 - Remove direct call functionality from Loop's backend. r=mikedeboer <Mark Banner>
> f5f9ce8 Bug 1209686 - Remove Standalone header from Loop, r=mardak <David Critchley>
> 559e525 Bug 1210774 - Upgrade Loop's use of eslint (to 1.6.x) and eslint-plugin-react (to 3.5.x). r=Mardak NPOTB DONTBUILD <Mark Banner>
> d55d4fa Bug 1131542 - Loop button on toolbar needs different tooltips to explain colours/state. r=Standard8 <Manuel Casas>
> 1920e94 Bug 1212079 - Removed contact scripts from index, r=dmose <Chris Rafuse>
> 986f2a5 Bug 1203159 - Rewrite DevTools resource URLs. r=ochameau <J. Ryan Stinnett>
> a4512f7 Bug 1216368 - Fix the panel views in Loop's ui-showcase - fake-Mozloop was missing a return statement. r=Standard8 <David Critchley>
> 671440a Bug 1215455 - Use eslint --fix to turn on additional rules [r=Standard8] <Ed Lee>
> 4563590 Bug 1215455 - eslint no-multi-spaces [r=Standard8] <Ed Lee>
> 14c11fb Bug 1215455 - eslint array-bracket-spacing [r=Standard8] <Ed Lee>
> cf5f029 Bug 1215455 - eslint object-curly-spacing [r=Standard8] <Ed Lee>
> 3164ac9 Bug 1215455 - eslint space-after-keywords [r=Standard8] <Ed Lee>
> 8984b26 Bug 1215455 - eslint space-before-blocks [r=Standard8] <Ed Lee>
> 95c75f3 Bug 1215455 - eslint space-before-function-paren [r=Standard8] <Ed Lee>
> b8d6bd8 Bug 1215455 - eslint operator-assignment [r=Standard8] <Ed Lee>
> 4ca7c2f Bug 1215455 - eslint space-in-parens [r=Standard8] <Ed Lee>
> 02291fb Bug 1215455 - eslint react/jsx-curly-spacing [r=Standard8] <Ed Lee>
> d2641da Bug 1215455 - eslint consistent-return [r=Standard8] <Ed Lee>
> 4299656 Bug 1217335 - Room context is no longer shown when loading the Loop standalone UI. r=Mardak <Mark Banner>
> 0dad4c8 Bug 1217369 - "Welcome to ..." has extra padding on Loop's standalone UI making it feel strange. r=mikedeboer,ui-review=sevaan <Mark Banner>
> 5da6b02 Bug 1213848 - Change the Loop panel display when a user enters their own room to stop them entering other rooms [r=mikedeboer] <Ed Lee>
> 28e48f0 Bug 1213336-Update Hello standalone npm version, r=Standard8, NPOTB DONTBUILD <Dan Mosedale>
> 46113b5 Bug 1205684 - Video Window height pushes down context and covers a part of it [r=mikedeboer] <Manuel Casas>
> 586184c Backed out changeset 79a231b4477d (bug 1205684) for Mn loop bustage <Wes Kocher>
> 79b117a Bug 1218405 - Change Loop's standalone background for the visual refresh/latest designs. r=dmose <Mark Banner>
> dd78856 Bug 1216551 - Fix an issue with Loop's unit tests failing when no devices are installed, due to bad stubbing. r=Mardak <Mark Banner>
> 316469c Bug 1218450 - The width of the tile shown on Loop's standalone when you're the only person in the room is wrong, giving a bad layout. r=Mardak <Mark Banner>
> 8ec6671 Bug 1203802 - Websocket Frame Listener API for devtool Network Inspector - part 1 - WindowID added into WebSocketChannel, r=michal <Andrea Marchesini>
> 167aaf2 Merge m-c to fx-team, a=merge <Wes Kocher>
> 9d22ece Bug 1205684 - Video Window height pushes down context and covers a part of it. r=mikedeboer <Manuel Casas>
> 57d50fc Bug 1199815 - Replace Error Summary at bottom of Loop's ui-showcase with React Component. r=Standard8 <Fernando Campo>
> e3ebe84 Bug 1214582 - Adjust how room titles are displayed/managed in Loop's UI. r=Standard8 <Manuel Casas>
> b8555d5 Bug 1213851 - Display only active room when user enters room [r=Mardak] <David Critchley>
> 64dd7d2 Bug 1213851 - test bustage fix when rebasing on bug 1214582 [r=Mardak] <David Critchley>
> 6ecd092 Bug 1212357 - Update the layout of the rooms list items for user journey. r=mikedeboer <Manuel Casas>
(Assignee)

Comment 1

2 years ago
Bug filed not quite right:

•Standard8> Mardak: err, bug 1221240 isn’t quite what was agreed - we’d just revert a couple of strings and fix up some UI
Status: ASSIGNED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.