Closed Bug 1221272 Opened 9 years ago Closed 8 years ago

SkRegion_path.cpp:301: failed assertion "top <= bot"

Categories

(Core :: Graphics, defect)

defect
Not set
critical

Tracking

()

RESOLVED FIXED
Tracking Status
firefox45 --- affected

People

(Reporter: jruderman, Unassigned)

References

Details

(Keywords: assertion, testcase, Whiteboard: [gfx-noted])

Attachments

(2 files)

Attached file testcase
Using a debug build on Mac:

gfx/skia/skia/src/core/SkRegion_path.cpp:301: failed assertion "top <= bot"

Same assertion as bug 746491, but I can't reproduce that bug on trunk, at least on Mac (it was reported on Linux).
Attached file stack
Fixed in newer Skia update, marking as dependent.
Depends on: 1082598
Whiteboard: [gfx-noted]
Fixed by Skia update.
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Creator:
Created:
Updated:
Size: