Home and End keys do nothing outside of text input controls

VERIFIED FIXED

Status

()

P3
minor
VERIFIED FIXED
19 years ago
19 years ago

People

(Reporter: cpratt, Assigned: joki)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [TESTCASE] "Home" key needs to scroll to top of page)

(Reporter)

Description

19 years ago
Build ID: 1999082008
Platform: Windows NT, Mac OS, Linux

To reproduce:
- Launch apprunner
- Load a long page such as http://www.macintouch.com
- Scroll down the page using Page Down
- Press the Home key

Result: Nothing happens.

Expected result: You should return to the top of the page,
(Assignee)

Comment 1

19 years ago
Is this a Mac thing?  My WinNT 4.5 version doesn't do this.
(Reporter)

Comment 2

19 years ago
This isn't a Mac-specific thing, no. The thing is that this feature is missing
(either by design or omission) in Communicator 4.x. The Home key should take you
up to the very top of the page; that's standard behavior in other applications
such as Word and IE.

Updated

19 years ago
Whiteboard: [TESTCASE] "Home" key needs to scroll to top of page

Comment 3

19 years ago
Verifying the bug report - it is absolutely definitive and cannot be simplified
any further.

(In case you're wondering, I'm just collecting Bugathon bounties :-)
(Reporter)

Updated

19 years ago
Summary: Home key does nothing → Home and End keys do nothing outside of text input controls
(Reporter)

Comment 4

19 years ago
Updating bug to reflect that the End key doesn't do anything either. The End key
should scroll down to the bottom of a Web page.

Note that Home and End keys do different things depending on context. Behavior
in text editing contexts is covered in bug 13277.
(Assignee)

Updated

19 years ago
Status: NEW → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → FIXED
(Assignee)

Comment 5

19 years ago
I fixed this today but somehow set up the keys backwards.  Right now home goes
to the end and end goes to the top.  Oops.  Anyway, the corrected version will
be in this evening.  Marking fixed.

Updated

19 years ago
Status: RESOLVED → VERIFIED

Comment 6

19 years ago
Verified fixed.
You need to log in before you can comment on or make changes to this bug.