Closed Bug 1221395 Opened 7 years ago Closed 4 years ago

Horizontal overscroll bounce animation frequently won't play on home screen

Categories

(Core :: Panning and Zooming, defect, P3)

defect

Tracking

()

RESOLVED WONTFIX

People

(Reporter: mauricio, Unassigned)

Details

(Keywords: foxfood, polish, Whiteboard: [bzlite][gfx-noted])

Attachments

(1 file)

User-Agent: Mozilla/5.0 (Mobile; rv:45.0) Gecko/45.0 Firefox/45.0

When you do horizontal extra scroll, it won't show it's 'jelly' style if you did not hold it for a few seconds. But it will get jelly if you hold it, let's say two mississippis.

The glitch is not present on vertical extra scroll, since it will get the jelly effect all the time.
Attached image 2015-11-03-20-48-59.png
I can still replicate this, even with the patches from bug 1221186 and bug 1216355 applied - it looks like there's still an edge-case that isn't accounted for here. kats, any ideas?
Component: Gaia::Feedback → Panning and Zooming
Flags: needinfo?(bugmail.mozilla)
Product: Firefox OS → Core
Summary: Horizontal extra scroll won't jelly → Horizontal overscroll bounce animation frequently won't play on home screen
I don't understand the STR. What do you mean by "jelly" style? What are you holding for a few seconds?
Flags: needinfo?(bugmail.mozilla) → needinfo?(mauricio)
(In reply to Kartikaya Gupta (email:kats@mozilla.com) from comment #3)
> I don't understand the STR. What do you mean by "jelly" style? What are you
> holding for a few seconds?

On the home screen, scrolled to the top, drag towards the right (causing horizontal overscroll on the apps list) and let go. Most of the time, you won't trigger a horizontal overscroll animation, it will just animate directly back to the not-overscrolled state (with no bounce ('jelly')).

This doesn't seem to happen if you scroll vertically at the same time, or as the original report says, if you hold your finger still for around 2-3 seconds or so before letting go. It seems to be some kind of bad interaction with the inner container's scrolling, but I can't pin down the exact circumstance (but it's very easy to reproduce).
Flags: needinfo?(mauricio)
Ah, thanks for the clarification. I can reproduce it as well. Something to look at but I'm going to classify this as low priority/polish.
Thank you guys!
Keywords: polish
Whiteboard: [bzlite] → [bzlite][gfx-noted]
B2G: we won't work on that.
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.