[FIX] disable 'Translate' menu item for images

VERIFIED FIXED in mozilla0.9.9

Status

--
minor
VERIFIED FIXED
17 years ago
5 years ago

People

(Reporter: aha, Assigned: Biesinger)

Tracking

Trunk
mozilla0.9.9
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment, 1 obsolete attachment)

(Reporter)

Description

17 years ago
Translation of image is still irelevant (AFAIK there isn't any translator with
built-in OCR), so this menu item should be disabled for them (actually does
nothing or just redirecting).

Gecko/2002012608/WinNT4

Comment 1

17 years ago
hrm
Assignee: asa → blaker
Component: Browser-General → XP Apps: GUI Features
QA Contact: doronr → sairuh

Comment 2

17 years ago
The mimetype-exposing code added in bug 73847 may be useful here.
Depends on: 73847
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Windows NT → All
Hardware: PC → All

Updated

17 years ago
Target Milestone: --- → Future
->morse, who's working on menu items.
Assignee: blaker → morse
Blocks: 108099
taking
Assignee: morse → cbiesinger
Target Milestone: Future → mozilla0.9.9

Comment 6

17 years ago
Comment on attachment 69949 [details] [diff] [review]
patch

sr=blake

This should not visibly affect page load times at all.	If for any reason it
does, of course, we'll have to back it out.
Attachment #69949 - Flags: superreview+

Comment 7

17 years ago
Comment on attachment 69949 [details] [diff] [review]
patch

biesi will fix whitespace and change the regexp to ^image/
Attachment #69949 - Flags: review+
putting [FIX] in summary instead of URL field
Summary: disable 'Translate' menu item for images → [FIX] disable 'Translate' menu item for images
fixed
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED
Created attachment 69982 [details] [diff] [review]
fixes strict warning

ok, the patch introduced a strict warning. this patch fixes it.
Attachment #69949 - Attachment is obsolete: true

Comment 11

17 years ago
is there another patch for disable to Text Zoom too for images?

Updated

17 years ago
Attachment #69982 - Flags: review+

Comment 12

17 years ago
Comment on attachment 69982 [details] [diff] [review]
fixes strict warning

sr=blake
Attachment #69982 - Flags: superreview+

Comment 13

17 years ago
i've filed http://bugzilla.mozilla.org/show_bug.cgi?id=126059 on more disable 
on images
Does this need to be reopened?  It's been backed out, right?
yes, it was backed out, but I checked it in again when the backout showed no
changes to Txul time.
(Maybe) Because of this patch, I'm getting a Javascript-error, 
which says there is something wrong in nsBrowserStatusHandler.js line 256.

The problem is that sometimes the throbberElement remains in busy-state.

If I change "ctype = aRequest.QueryInterface(nsIChannel).contentType;"
to "try{ ctype = aRequest.QueryInterface(nsIChannel).contentType;} catch(ex){}"
the throbber works as expected.
smaug: *sigh*. ok, I will fix this as part of bug 126059

vrfy'd for at least the Translate item... :)

*zap*
Status: RESOLVED → VERIFIED
Product: Core → Mozilla Application Suite

Updated

11 years ago
Component: XP Apps: GUI Features → UI Design
You need to log in before you can comment on or make changes to this bug.