Closed Bug 1221472 Opened 4 years ago Closed 4 years ago

[TV Browser] Some histories show only URLs with blank title

Categories

(Firefox OS Graveyard :: Gaia::TV::Browser, defect, P1)

ARM
Gonk (Firefox OS)
defect

Tracking

(b2g-v2.5 fixed)

RESOLVED FIXED
FxOS-S11 (13Nov)
Tracking Status
b2g-v2.5 --- fixed

People

(Reporter: cynthiatang, Assigned: selee)

References

Details

(Whiteboard: [ft:conndevices][partner-cherry-pick])

Attachments

(1 file)

Commit f17421e9a23b9dbd88c41347f1b9c442a97f48e0
Merge: 06de78d e7dd557
Author: gasolin <gasolin@gmail.com>
Date:   Tue Nov 3 13:37:26 2015 +0800

STR:
 1. Launch Browser
 2. Sign in to sync History
 3. Check the history

Actual Result:
 - Some histories show only URLs without titles

Expected Result:
 - Desktop's history and TV's history should be the same
Sean, could you take a look at this, please? Thanks!
Blocks: fxos-sync
Flags: needinfo?(selee)
Priority: -- → P1
Target Milestone: --- → FxOS-S11 (13Nov)
QA Whiteboard: [COM=TV Firefox Account]
Got it!
Assignee: nobody → selee
Flags: needinfo?(selee)
Comment on attachment 8683147 [details] [review]
[gaia] weilonge:seanlee/TVBrowser/master/Bug1221472 > mozilla-b2g:master

Hey Dan, Could you help to review the patch? Thank you!
Attachment #8683147 - Flags: review?(dhuang)
Whiteboard: [ft:conndevices] → [ft:conndevices][partner-cherry-pick]
Comment on attachment 8683147 [details] [review]
[gaia] weilonge:seanlee/TVBrowser/master/Bug1221472 > mozilla-b2g:master

Look good to me! Thanks for the effort!
Attachment #8683147 - Flags: review?(dhuang) → review+
Summary: [TV Browser] Some histories show only URLs → [TV Browser] Some histories show only URLs with blank title
Thanks for reviewing this! :)

landed on master: https://github.com/mozilla-b2g/gaia/commit/8950676a273bd902a9ae63d7ef9afc59e14ebd81
gaia-test: https://treeherder.mozilla.org/#/jobs?repo=gaia&revision=4e30caa53692f37822ef0abcdb4caaf824be14d5
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Blocks: TV_FxAccount
Comment on attachment 8683147 [details] [review]
[gaia] weilonge:seanlee/TVBrowser/master/Bug1221472 > mozilla-b2g:master

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): bug 1194108
[User impact] if declined: See the blank title of a history record without title.
[Testing completed]: Tested in B2G desktop build.
[Risk to taking this patch] (and alternatives if risky): None
[String changes made]: None
Attachment #8683147 - Flags: approval-gaia-v2.5?
Comment on attachment 8683147 [details] [review]
[gaia] weilonge:seanlee/TVBrowser/master/Bug1221472 > mozilla-b2g:master

Approved for 2.5 uplift.

Thanks
Attachment #8683147 - Flags: approval-gaia-v2.5? → approval-gaia-v2.5+
You need to log in before you can comment on or make changes to this bug.