Stop mutating state in snapshots reducers

RESOLVED DUPLICATE of bug 960780

Status

()

Firefox
Developer Tools: Memory
RESOLVED DUPLICATE of bug 960780
2 years ago
2 years ago

People

(Reporter: fitzgen, Unassigned)

Tracking

(Blocks: 1 bug)

Firefox Tracking Flags

(Not tracked)

Details

We are creating new lists of the same snapshots and mutating our target snapshot. We shouldn't do any mutating at all here.

https://dxr.mozilla.org/mozilla-central/rev/f742b9412ed5aace90ad863b276faae0641090a8/devtools/client/memory/reducers/snapshots.js#11-13,24-25,32-33,38-40,45-49,54-58,64
Has STR: --- → irrelevant
This was done as part of the diffing UI.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 960780
You need to log in before you can comment on or make changes to this bug.