Hover menus no longer work

RESOLVED WORKSFORME

Status

()

Core
Layout
P4
normal
RESOLVED WORKSFORME
16 years ago
3 years ago

People

(Reporter: Simon Harvey, Assigned: Marc Attinasi)

Tracking

Trunk
mozilla1.2alpha
x86
Windows 98
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Win98; en-US; rv:0.9.8+) Gecko/20020127
BuildID:    2002 01 27 08

It's now impossible for me to go back and verify that hover menus did actually
work on my last build, but I'm fairly certain that they did and they certainly
don't on this one. Is this a case of someone being puritannical? A lot of large
and small web-sites (such as the Indie, given as an example above) use them, and
they are not especially demanding on browser speed. Could we have them back,
please? Hover menus are so widespread now that it's fair to say that if a
browser can't handle them, it's a bug. Even if the bug is intentional.

Reproducible: Always
Steps to Reproduce:
1. Go to the Independent web-site (http://enjoyment.independent.co.uk/)
2. Move the mouse cursor over one of the menus on the left hand side of the
screen -- the lists of subdivisions beneath the major headings. E.g., Enjoyment
> Books. This should pop up a sub-menu, listing news, reviews, features, interviews.
3. Observe nothing happening.

Actual Results:  Nothing happens.

Expected Results:  The appearance of a little sub-sub-menu in a pale box when
the mouse cursor runs over one of the submenu headings (e.g., Books).

Comment 1

16 years ago
Layout?
Assignee: trudelle → attinasi
Status: UNCONFIRMED → NEW
Component: XP Apps → Layout
Ever confirmed: true
QA Contact: sairuh → petersen

Comment 2

16 years ago
Changing QA Contact
QA Contact: petersen → amar

Comment 3

16 years ago
Umm, on Linux I tried it on 2002012621, and then on several older releases as
far back as Mozilla 0.7, and I couldn't get the hover menus to work. (I see them
with Navigator 4X.) Are you sure that they ever worked ? 

Updated

16 years ago
Target Milestone: --- → mozilla1.2

Comment 4

16 years ago
 Changing the priority to P4.
Keywords: qawanted
Priority: -- → P4

Updated

16 years ago
Blocks: 113492

Comment 5

16 years ago
On WinME Page behaved exactly the same on I.E. 5.5 and Mozilla Nightly Build
13-mar-2002. -- CharlesShuller@yahoo.com
(Reporter)

Comment 6

16 years ago
Slight problem: the Independent web-site no longer uses hover menus, nor does 
the Post Office -- and I don't know of another site that does. Does this 
suggest the problem can be abandoned? I's say not, because there will be other 
sites that use them, but developers will have to find their own test page in 
the short term. Sorry I can't help with that one. SH. editor@arts-etc.org

Comment 7

16 years ago
This might have been an "evangelism" problem. As I say in comment #3 the menus
did not work in any of the older builds I tried, contrary to what the title
suggests. Since nobody produced a reduced testcase, and the site has changed, I
suggest abandoning (INVALID or WORKSFORME ?).

Comment 8

16 years ago
OK guys... I've found a page that does use such popup-menus! it's
http://www.nvidia.com/ =) and the menu does display in IE and Opera. And i've
been there with mozilla someday to fetch the detonator, and it did work then.
now it does not. seems to be the same problem.

the popups should appear when hovering the silvery buttons on top of the page. i
might even make you a testcase out of this, if you like.. and i find time for
this. but first: reporter please verify that this is the same bug.
(Reporter)

Comment 9

16 years ago
Using test site

http://www.nvidia.com/

as suggested by Daniel.Steinberger@gmx.de, my current build 032603 does not 
give hover menus -- recognises hover condition (pointer appears) but no hover 
menus. I'm running without Flash & Shockwave plugins, though I don't think this 
is a factor. This could be Moz talking to W98, not Moz alone. Could users on 
all platforms please visit this site and try out the hovers? Mouseover the 
silver buttons at the top.

Comment 10

16 years ago
Using build 2002031106 on a Mac (OS 9.2) these hovers work, after a fashion, and
eventually.  I can't quite pin point at what point they start working though. 
And I got the impression it was to do with the bit of he image that I was
hovering over - right at the bottom of the silver bar seemed to trigger them
working.  But nothing worked until I had actually tried to load a couple of the
pages - oh wait - maybe they just don't work on the home page but do on some of
the other pages - try clicking on the products button and see if they work after
the products page has loaded.

Comment 11

16 years ago
With 2002042608 on Win2k these hover menus do not work/open. With IE5 they do.

Comment 12

16 years ago
For the nVidia site, at least, this is not a Mozilla bug.

The reason that Moz fails to display the menus is that the nVidia server checks
the UA string and serves Moz an entirely different page to that it serves to IE
and Opera - one without hover menus. (page size is 28435KB with a UA of
"Mozilla/4.0 (compatible; MSIE 6.0; Win32)" but is just 20374KB with a
Mozilla-style UA string)

If one adds user_pref("general.useragent.override", "Mozilla/4.0 (compatible;
MSIE 6.0; Win32)"); to prefs.js (to pretend that we're running IE 6), the nVidia
site displays perfectly well in Mozilla (build 2002081004).

<rant>
I wonder just how many of the bugs tracked by 113492 are due to lazy web
designers deciding that because their menus failed in some antique version of
Mozilla, they'll never work in Mozilla, and so they cheat by serving up a broken
version of their page just to ensure that it WILL never work in Mozilla!
</rant>

Comment 13

16 years ago
> and Opera - one without hover menus. (page size is 28435KB with a UA of
> "Mozilla/4.0 (compatible; MSIE 6.0; Win32)" but is just 20374KB with a

Sorry, I meant bytes, not KB. The nVidia site may be bloated, but it's not
*that* bad!

Comment 14

15 years ago
The attached URL does not have the problem anymore and Nvidias menu is not a
Mozilla bug, resolve as WFM? Or Tech Evangelism bug.

Comment 15

15 years ago
> It's now impossible for me to go back and verify that hover menus did
> actually work on my last build, but I'm fairly certain that they did
> and they certainly don't on this one.

I'd say the site has removed the menu, so you don't see it
-> wfm
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → WORKSFORME

Updated

15 years ago
No longer blocks: 113492
Keywords: qawanted
You need to log in before you can comment on or make changes to this bug.