Closed Bug 1221616 Opened 4 years ago Closed 4 years ago

Use ID2D1CommandList instead of a bitmap for temporary D2D drawing

Categories

(Core :: Graphics, defect)

defect
Not set

Tracking

()

RESOLVED FIXED
mozilla45
Tracking Status
firefox45 --- fixed

People

(Reporter: bas.schouten, Assigned: bas.schouten)

References

Details

Attachments

(1 file)

Right now we use a temporary bitmap that we create and keep around for all D2D DrawTargets in order to execute temporary drawing for non-operator over and other drawing purposes. We can do better by using CommandLists, this will bring down our memory footprint as well as hopefully reducing the overhead caused by having to clear and blend a larger than required temporary drawing target.
Attachment #8683166 - Flags: review?(jmuizelaar)
Attachment #8683166 - Flags: review?(jmuizelaar) → review+
https://hg.mozilla.org/mozilla-central/rev/e4944eb37eec
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla45
Depends on: 1246641
Assignee: nobody → bas
Depends on: 1259785
You need to log in before you can comment on or make changes to this bug.