Completely remove backfill UI on try, go back to just a retrigger button

RESOLVED DUPLICATE of bug 1207460

Status

Tree Management
Treeherder
RESOLVED DUPLICATE of bug 1207460
2 years ago
2 years ago

People

(Reporter: kats, Unassigned)

Tracking

Details

In the recent past, the "Retrigger" button in the TH UI was replaced with a dropdown that contains "retrigger" and "backfill" options. I'm sure this is nice for sheriffs but it makes retriggering jobs harder in that it goes from one click to two clicks with a mouse-move in between. Not the end of the world but pretty annoying when you want to do 50 retriggers of a single job (e.g. debugging an intermittent failure).

I suggest that when jobs are on the try tree, we do what we used to do and have a single-click retrigger button. I'm assuming here that "backfill" is not useful on try as it requires a linear series of pushes.
The uselessness of backfill on try is bug 1207398, but that doesn't plan on taking you back to a button, it plans on giving you a menu with two items, one disabled.

The real answer is to just completely ignore the treeherder UI whenever you can, and this is a whenever that you can: just select the job and press the 'r' key 50 times, or for buildbot jobs rather than taskcluster jobs, open self-serve from the downarrow on the right side header of the push menu and choose the BuildAPI menuitem, where you can retrigger by just typing 50 in a textinput and clicking a rebuild button.
Summary: Make it easier to retrigger jobs on try → Completely remove backfill UI on try, go back to just a retrigger button

Updated

2 years ago
See Also: → bug 1207460
OMG, keyboard shortcuts for retrigger! I am happy now. I should have looked for that sooner :)
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1207460

Updated

2 years ago
See Also: bug 1207460
You need to log in before you can comment on or make changes to this bug.