API endpoint to download signed add-on file

RESOLVED FIXED

Status

RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: kumar, Assigned: kumar)

Tracking

Details

(Whiteboard: [qa-])

We need a v3 endpoint that lets you download a signed file with JWT auth. The version upload API should return this URL (which would fix bug 1221748).
Assignee: nobody → kumar.mcmillan
Blocks: 1206158
Duplicate of this bug: 1221250

Comment 2

3 years ago
Commits pushed to master at https://github.com/mozilla/olympia

https://github.com/mozilla/olympia/commit/c32b93c418c018580e927fb3f8d9f1fe21bec754
API for getting signed files (bug 1221759)

https://github.com/mozilla/olympia/commit/6966546abd344d8421020150455de7dc279f8443
Merge pull request #880 from kumar303/signed-download

API for getting signed files (bug 1221759)
https://github.com/mozilla/olympia/pull/880
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
Whiteboard: [qa-]
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.