[New Homescreen] undeleteable apps will shake when in edit mode and moving to a different location and back to original without letting go

RESOLVED INVALID

Status

Firefox OS
Gaia::Homescreen
RESOLVED INVALID
3 years ago
3 years ago

People

(Reporter: AdamA, Unassigned)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(b2g-master affected)

Details

(Whiteboard: [2.5-Daily-Testing][Spark][Systemsfe], URL)

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
Created attachment 8683380 [details]
logcat

Description:
If the user is in edit mode on the new homescreen and selects one of the apps that cant be deleted and then moves it away from its current location and back to the original location without letting go of the app it will shake as they let go and leave it in the original position. this shake does not occur when teh app is moved to a new location.

Repro Steps:
1) Update a Flame to 20151104030208
2) Long press a deletable app to enter edit mode
3) Press and hold an app that isnt deletable
4) Move the app to a different location then move it back to the original location without letting go
5) Lift finger from screen
6) Observe app as user lets go

Actual:
The app shakes when let go

Expected:
It is expected that the app does not shake when left in the original position

Environmental Variables:
Device: Flame 2.6 [512mb][Full Flash]
Build ID: 20151104030208
Gaia: 47da49f8206788d70d834c3a63d9245d50c89103
Gecko: 6077f51254c69a1e14e1b61acba4af451bf1783e
Gonk: 205ac4204bbbb2098a8046444acba551ba5dc75a
Version: 45.0a1 (2.6)
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:45.0) Gecko/45.0 Firefox/45.0

Repro frequency: 10/10
See attached: video clip(https://youtu.be/m2ugAEMBvzI), logcat
(Reporter)

Comment 1

3 years ago
This issue DOES occur on Aries 2.6.

Environmental Variables:
Device: Aries 2.6 [Full Flash]
BuildID: 20151030120435
Gaia: 91cac94948094cfdcd00cba5c6483e27e80cb3b0
Gecko: c2534acb485963331d67bbc5c07f0d862ed56bf5
Gonk: a19052e4389c3ae2d8fc3e7a74a475401baacc56
Version: 45.0a1 (2.6) 
Firmware Version: D5803_23.1.A.1.28_NCB.ftf
User Agent: Mozilla/5.0 (Mobile; rv:45.0) Gecko/45.0 Firefox/45.0

Result:
The app shakes when let go in original position
---------------------------------------
This feature is not in the Flame 2.5 new homescreen because edit mode was added after branching to 2.6.
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
Summary: [New Homescreen] undeleteable apps will shake when in edit mode when moving to a different location and back to original without letting go → [New Homescreen] undeleteable apps will shake when in edit mode and moving to a different location and back to original without letting go
Teri, can you take a look at this please?
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker) → needinfo?(twen)

Comment 3

3 years ago
Looks like edit mode change is from https://bugzilla.mozilla.org/show_bug.cgi?id=1218805. 
Found no spec to reference to. NI? Chris to confirm if system apps shake is expected.
Flags: needinfo?(twen) → needinfo?(chrislord.net)

Comment 4

3 years ago
This is expected in that an action that would otherwise select the app can't occur (because it's not deletable or editable) - but n?ezoehunt to confirm/make sure/decide if we want to do something different :)
Flags: needinfo?(chrislord.net) → needinfo?(ehunt)
In this homescreen scheme, the shaking is a reminder that the app isn't deletable or editable. So this behavior is expected and by design.
Flags: needinfo?(ehunt)

Updated

3 years ago
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.