[Marketplace][legal docs]: localized docs not appearing

RESOLVED DUPLICATE of bug 1208231

Status

Marketplace
General
RESOLVED DUPLICATE of bug 1208231
2 years ago
2 years ago

People

(Reporter: CocoMo, Assigned: clouserw)

Tracking

Points:
---

Details

Attachments

(1 attachment)

(Reporter)

Description

2 years ago
Hello Wil,

Not sure who is in charge of this, but Casey did an audit on localized legal docs and noticed quite a few were not on production

Kohei did his part to find out the root cause. He reported that the reason was that the sync was manual, not automatic:

marketplace.firefox.com

    https://marketplace.firefox.com/privacy-policy
    https://marketplace.firefox.com/terms-of-use
    manually synced: https://github.com/mozilla/zamboni/tree/master/media/docs

Could you help to get this resolved?  There are random updates from time to time, not to mention the new languages added don't get published at all.

Thank you,
Peiying
(Reporter)

Updated

2 years ago
Summary: [Marketplace][legal docs]: localized docs not automatically updated → [Marketplace][legal docs]: localized docs not automatically updated on production
(Assignee)

Comment 1

2 years ago
We we're waiting for the new package I think, before extracting again.  David - do you want me to extract the legal docs?
Flags: needinfo?(ddurst)
We manually synced these last week, and only dev agreements had changed.

I'm confused -- just looking at privacy policy, not only is it the same in both repos (legal docs and zamboni), but also the localizations are up-to-date. I haven't looked at anything else, because I want to make sure we're talking about the same thing.

Where can I see an example of something that's not on production?
Flags: needinfo?(ddurst) → needinfo?(pmo)
Created attachment 8684403 [details]
Screen Shot 2015-11-06 at 12.28.56 PM.png

Here's a screen shot of what we're talking about. This is the bn-BD page for the MP privacy notice. The rest of the page is in the right language but the text for the actual notice (which is translated in the github repo) is in English.
So the text is correct, but the actual localization isn't happening -- we're showing the English version instead, for all locales.
Flags: needinfo?(pmo)

Updated

2 years ago
Summary: [Marketplace][legal docs]: localized docs not automatically updated on production → [Marketplace][legal docs]: localized docs not appearing on production
This is failing on all envs.
Summary: [Marketplace][legal docs]: localized docs not appearing on production → [Marketplace][legal docs]: localized docs not appearing

Updated

2 years ago
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1208231
(Reporter)

Comment 7

2 years ago
Want to comment on bn-BD, ideally bn-IN should be ok (or "bn" to exact".  But the decision was to have two versions, but the content is the same. We can make a copy of bn-IN to bn-BD.
You need to log in before you can comment on or make changes to this bug.