Closed Bug 1221817 Opened 5 years ago Closed 5 years ago

Make IntlHelper reset on moztimechange

Categories

(Firefox OS Graveyard :: Gaia::L10n, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(b2g-v2.5 fixed, b2g-master fixed)

RESOLVED FIXED
Tracking Status
b2g-v2.5 --- fixed
b2g-master --- fixed

People

(Reporter: zbraniecki, Assigned: zbraniecki)

Details

Attachments

(1 file)

IntlHelper reacts to timeformatchange and languagechange, but not moztimechange which is what we use to notify clients about timezone changes.
Assignee: nobody → gandalf
Status: NEW → ASSIGNED
Comment on attachment 8683389 [details] [review]
[gaia] zbraniecki:1221817-observer-moztimechange-in-intlhelper > mozilla-b2g:master

Thanks to how centralized everything, it's easy to extend our IntlHelper to handle moztimechange.

We're still waiting for bug 1208808 to see the result, but this will make us reset cache on moztimechange.
Attachment #8683389 - Flags: review?(stas)
Comment on attachment 8683389 [details] [review]
[gaia] zbraniecki:1221817-observer-moztimechange-in-intlhelper > mozilla-b2g:master

Nice.  The IntlHelper pays off :) r=me with a comment left on github.
Attachment #8683389 - Flags: review?(stas) → review+
Thanks!

Commit: https://github.com/mozilla-b2g/gaia/commit/a7958d74017d84ac008cb433a9c2610ba31c9a19
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Comment on attachment 8683389 [details] [review]
[gaia] zbraniecki:1221817-observer-moztimechange-in-intlhelper > mozilla-b2g:master

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): IntlHelper
[User impact] if declined: Cached DateTime objects don't get recreated on time change
[Testing completed]: master for a week, tests and device
[Risk to taking this patch] (and alternatives if risky): very low
[String changes made]: none
Attachment #8683389 - Flags: approval-gaia-v2.5?
Comment on attachment 8683389 [details] [review]
[gaia] zbraniecki:1221817-observer-moztimechange-in-intlhelper > mozilla-b2g:master

Approved for 2.5

Thanks
Attachment #8683389 - Flags: approval-gaia-v2.5? → approval-gaia-v2.5+
You need to log in before you can comment on or make changes to this bug.